cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS 550D - Polaroid RC-6 remote control / issues

Steventhehun
Apprentice

Hy All!

I just recently bought an RC-6 remote control for my Canon EOS 550D camera, but it simply doesn't work. What I already tried:

- followed the instructions based on the manual (official manual, page 204)
- switched the camera to auto mode
- set the self-timer to remote mode
- cleaned IR sensor on the camera
- switched the modes on remote control

When I press the button on the remote, camera doesn't focus, doesn't take a photo, doesn't do anything (I tried of course in front of the camera, pointed to the IR sensor). Quick info, remote control is not an original one, it's a Polariod, but it shouldn't be a problem.

If it won't work, what is your opinion about any 2.4Ghz remotes? 2 devices, sender and receiver, receiver has cable connection to the camera, the sender is the remote. It has many other option on the remote, not just 1 button for the photoshooting, it seems more complex and more useful than RC-6. I bought this one, because I was pretty sure that it will work, as infra connection is not a rocket science, but I was wrong..

Many thanks in advance!

 

4 REPLIES 4

Arthur
Moderator
Moderator

Welcome to The Canon Community, and thank you for your inquiry!

We appreciate your participation, however, we need to let you know that the Canon Community is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please CLICK HERE and select your country or region for your support needs.

You're welcome to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

kvbarkley
VIP
VIP

Did you change the battery in the remote?

And this is confusing: " remote control is not an original one, it's a Polariod, but it shouldn't be a problem."

Hello!

No, I didn't, I'll try, but I don't think that this is the problem. It's clearly visible, that the small led on the remote is flashing when I press the button.
I mean it's not a Canon RC-6, but a Polariod RC-6. Same product, but it's perfectly compatible with 550D according the manual.

Changed the battery in the remote, issue still persists.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements