cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VIXIA HF G70 UVC not working? Can't power camera (over USB-C) if UVC *was* working?!

redrob
Contributor

My G70 arrived and I've tried three USB-C cables with it.  All three fit the camera just fine.  (this is good!)

The Bad? 

  1. None of my cables allow my computer to recognize the camera as a UVC camera.  The "USB Mode" is set in the camera to "Video Output (UVC)"
  2. I tried plugging the other end directly into a USB hub -- the battery does not charging or recognize that it's plugged in.
  3. Using the A/C adapter which comes with the camera (with USB end) *does* properly power the camera, which detects it and reports "DC IN" where the battery meter typically would otherwise be.

So -- this all looks like some bad news for us users.  My summary observation is:

  1. It is impossible to use the G70 as a UVC camera while also plugged into A/C power.  Both use the single USB port on the camera
  2. The USB port on the camera so far seems not to function using standard USB cables and bricks for either charging OR acting as UVC camera (when plugged into a computer).   Noting the camera says it requires 9V, and the adapter which ships with it reports it can output 5V (3A) or 9V (3A), my guess is the camera requires 9V over USB-C only to charge it, and it likely won't charge while also outputting a UVC signal (if that even works, which I could not test)

Has anyone here actually gotten the G70 to work successfully as a UVC camera?   Did it charge while outputting video?

Seeing as the G70 takes away several things from the G50 (e.g. removal of the mini-shoe), and only adds a better flip-out display and UVC, if UVC isn't working or practical here, it seems to me the G50 might be an overall better choice.

8 REPLIES 8

NatalyaP
Product Expert
Product Expert

Greetings redrob,

You may plug the USB Power Adapter PD-E1 to the DC IN terminal on the side of the camera to power the camera which would allow for you to connect the USB-C cable to the USB terminal of the camera to allow you to connect the camera to your computer. In case you're experiencing communication issues between the camera and computer, then we recommend on connecting the camera directly to a USB port of the computer instead of using a USB hub.

Thanks Natalya!   I did discover the 2nd USB port on the front-right for connecting with the computer for UVC output.  It worked properly this way, but I'm really disappointed that the camera does not implement audio over UVC -- seriously -- if you're going to have it look like a Webcam, add the USB audio device too like most Webcams do; without audio, it feels only like a half-baked solution and hardly useable as-is.

Will there be a firmware update to add audio over UVC?

Also, besides the Canon power adapter, can we use a generic 3rd party power charger to the camera since it's a USB-C plug?  If so, will any generic USB-C work if it supports Universal Power (so it can output 9V)?

slankslim
Apprentice

I'm having the same issue with trying to recharge my battery.  have you found a solution to get the battery to charge?  I haven't had a digital camera like this since the Mini Dv days.  I remember I would just plug the charger in the Dc port and the camera would light up and begin charging.  Is there a new way to activate the charging?

Oh -- it's not a problem for me anymore.  I hadn't realized the camera has two USB ports -- the one in the front-right is for UVC (Webcam to computer) -- the one in the back-right-top is the USB port for powering the camera (and charging the battery).  Works great for me!   Make sure you're using the adapter which came with the camera, or equivalent; a standard 5V brick I don't think will cut it.

slankslim
Apprentice

it’s not working for me. I even removed the battery to see if I could get power from the outlet, but I got nothing. My brick say 5.0A and right below it 9.0A. This is a first for me, I owned many cameras and all of the wall plugs worked. 

The Canon PD-E1?  Sounds like you're doing things right.. I know it's a ridiculous question since you clearly have experience -- is the cable plugged into the brick all the way (sorry.. gotta ask.. I've had silly mishaps before).  Confirming -- you're plugging it into the rear-right USB plug on the camera too, not the one in the front-right?

slankslim
Apprentice

Okay I just checked the brick and it says pd-e1. I just double checked to Make sure plugg is all the way in the brick. And yes I just double checked I’m plugged into the usb port at the rear top that is labeled DC -in… and side note I did plug into my android phone and it powered on and started charging, so I do have electricity coming through the pad-e1

i still have nothing 

Avatar
click here to view the gallery
Announcements