cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Photos with Vixia G60

JDHArt
Apprentice

I've had Vixia camcorders in the past so am fairly familiar with the basic menus and functions. However, with the G60, I can't seem to figure out how to take a still photo. When I press the photo button on screen or on the remote all it does is give me a focusing beep. I've tried every different photo setting I can find. Pressing the "record" button works fine.
Any guidance would be greatly appreciated.

1 ACCEPTED SOLUTION

Well... this is embarrassing. I just found out that it has been taking photos all along. My other HF Vixia made a shutter sound when it took photos and the g60 doesn't make any noise except for focus. Sorry. 🙂

View solution in original post

3 REPLIES 3

shadowsports
Legend
Legend

G60.png

 

In standby mode you should be able to press Photo or use the remote.  You should get focus lock and a shot.  

 

Ensure you have specified which card to save your photos on.  

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Yes. I am doing all that but when I press photo on the remote or the screen it just gives a focus beep and nothing else happens. The green record icon appears at the bottom of the screen. and a little camera icon appears on the upper right with the sd card selected - but only for a split second while it focuses. Then... nothing.

 

The only thing I wasn't sure of is if I was starting off in Record Standby mode. If by that, the manual means that I have the switch toggled to record instead of view recordings then I have that set correctly as well.  I can press record and it starts to "film" but photo doesn't do anything except refocus.

 

I see that I can upload a video to this forum. I can record what happens (or doesn't happen) and upload it here if anyone thinks that would help diagnose the issue.

Well... this is embarrassing. I just found out that it has been taking photos all along. My other HF Vixia made a shutter sound when it took photos and the g60 doesn't make any noise except for focus. Sorry. 🙂
Avatar
click here to view the gallery
Announcements