Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Vixia GX10 failure (power on, no picture, no menu)


Hi Canon community - 

I'm assuming this 4K camcorder needs service, if it's fixable at all - backlight; but no picture/no menu/unresponsive.  But I thought I'd ask if there was something I can try at home.  No misuse; the unit was in the same stationary position it's been in for months.


  1. If I unplug and replug it then go into playback (media) mode, it's fine; displays settings, plays back media etc.
  2. If I then switch it to camera mode - OR, if I start it in camera mode:
    There is a short buzz sound, the picture goes black, and it will no longer function, even set back to playback mode.

Other info:

  • 4 years old; but very light use.   Every now and then used for a few hours from a stationary position, with no operator.
  • Before this, I turned it off (plugged in) and noticed a couple days later that it was displaying something like  "do not turn off, update in progress" (I think - makes no sense, it's not connected to a network to get an update).  After awhile I turned if off anyway (message stayed on), unplugged it; only to return to the camera mode being unresponsive.





Hi, I have the exact same problem. Any solution yet?


Greetings Stevec323,

Followed everything in your post.  "Do not turn off, update in progress" and "plug / unplug it".  A few questions.  


Are you using the CA-946 for external power?

Does the behavior occur with the camera on battery power?  Do you have another battery to test with?

SD Card.  Do you have another card to test with?

**The update message.  The camera does not have the ability to self-update itself.

The update message is suspect.  It indicates the camera's FW is or was updated at some point, and the upgrade was not successful, or its FW is now corrupt.   

What FW is the camera running?   

Please check your SD card for a file such as "VNAx.FIM".  This is a camcorder firmware file.  

At this point, everything is pointing towards a FW issue. If the behavior happens with AC adapter or battery and with a different SD card, its the FW.  

I would not try and fix it myself.  Send it to Canon.  Quick turn around and guaranteed. 

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hey, thanks for the response.  Answers:

Power:   I use only the OEM power brick that came with the camcorder.  The result was the same with the power adaptor, or with battery.

I  believe I'd tried it with different SD cards, and no SD card, with same result (it's been 3 months).

Not sure what firmware the camcorder was running.  I thought about trying to update the firmware, but it didn't make sense to me that the firmware would fail (and cause a grinding noise), when the camera hadn't done anything for months, except now and then shoot a static image from a stationary position.

Anyway, I sent it in to Canon.  They responded with an estimate of $1750, but NO information about what they think the problem.  Also unclear if that's a high end estimate, or their actual estimate.  Either way, the camcorder is probably not even worth that much at 4 years old.  So it's sitting there while I decide what to do - probably have them send it back while I see if some mom-and-pop shop will give me a reasonable estimate.  But I would like SOME indication of what they think is wrong - need to follow up, but the camcorder isn't needed for any necessities any more.


Thats a hefty estimate.  Sounds mechanical in nature at that price point. Hopefully you'll receive word about the problem.   

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

click here to view the gallery