Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎08-21-2020

Pixma TS5320 refuses to connect to anything, won't ask for password when I try to connect to wifi

[ Edited ]

Hi all,

 

Hoping I can get some help on my Pixma TS5320.

 

I bought the printer for my apartment a couple weeks ago, and so far, I've been unable to get the printer to connect to anything. I've tried to connect through both my Windows computer and my Android computer, and both have given me generic errors about how they cannot communicate with the printer after getting as far as router setup. Both the software and the manual have essentially put me in a loop with regards to how to fix this.

 

I've also tried to connect my wifi through the printer itself, but despite the wifi needing a password, the printer refuses to let me enter a password and then tells me it can't connect to the router. (I do not have direct access to the wifi router, so I cannot change its settings to connect without a password.)

 

What am I doing wrong? Is there an easy fix for this?

 

Hoping to be able to salvage this so I can get some level of mileage out of the printer. Help would be much appreciated!

Esteemed Contributor
Posts: 3,473
Registered: ‎11-19-2017

Re: Pixma TS5320 refuses to connect to anything, won't ask for password when I try to connect to wif

Greetings,

Depending on the router and its configuration, you could have difficulty connectiing any wireless device.  Without access you could be in for some frustration.

 

Telling us "you can't", or "it won't" doesn't give a lot to go on I';m afraid.  Nor does "generic errors".

 

Windows:

Here are the steps for adding the device:

 

https://support.usa.canon.com/kb/index?page=content&id=ART175289

 

Considerations:

 

The printer's wireless radio only supports 2.4Ghz.  If the router uses SMART CONNECT or similar feature...  One SSID for both 5G and 2.4Ghz networks, the printer might not be able to connect. In a situation like this, creating separate networks for each broadcast usually helps. 

 

If this is not the issue, then you'll need to provide more information, detail the steps you performed and specific error information.  Otherwise all we are doing is guessing about what could be your problem.

 

Thanks,

 

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100 ~ImageClass MF644Cdw ~LBP622dw
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement