cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VIXIA HF G40 immediately shuts down with Sony LANC

jobbruggen
Apprentice

Hi everyone, new to this forum.

A simple question about using a LANC connection for control of my CANON HF G40 and HF G30.

When I connect the Sony LANC to my G40, it immediately shuts down. Same when first power off, then connect, it immediately shuts down when I power on. I thought these LANC connection were standardized?

Any suggestions appreciated.

Greetings from the Netherlands,

Job

IMG_7574.JPG

2 REPLIES 2

IamintheUK
Rising Star

I think you will find that, as the controllers contain circuitry,  the protocols used by different manufactures are different. I used one of these controllers (from Ebay) with my G40 and it was specified as being compatible with Canon.Lanc Controller.jpg

__________________________________________________________________________________________
EOS C100 mk2 with the Canon EF-S 18-135mm IS STM lens - Atomos Ninja 2 - Zoom H2n - Dell 8700 i7-4790 3.6Ghz, 24GB Ram, Win 10, Nvidia GTX 1060 6GB - DaVinci Resolve Studio 18.6.4 - Blackmagic Speed Editor - Presonus Faderport 1

jobbruggen
Apprentice

Thanks, Yes, I opened the Sony LANC handle bar and there is a lot of circuitry in there!

But no battery (which I expected) so it is getting the power from the camera LANC socket. Makes sense.

Best is probably to sell the handle bar separately from the tripod.

Greetings,

Job

 

Avatar
click here to view the press release
Announcements