cancel
Showing results for 
Search instead for 
Did you mean: 

No ETTL 580EX Speedlite with EOS RP

hwildeboer
New Contributor

Hi all,

 

Last week I upgraded my EOS 20D camera body to an EOS RP. My old 580EX (bought in 2005) speedlite flash unit works happily in ETTL mode with the old 20D body. However, when I mount it to my new EOS RP body it immediately switches to TTL mode and it wont let me switch to ETTL.

 

When I use the flash on my EOS RP it does flash at full power (which is to be expected in TTL mode). The RP does not recognize the flashunit in its menu (which is also expected because it is an old flash unit).


Does anybody know if the EOS RP supports ETTL mode on my old flash unit or if there is some sort of fault or setting I have to change such that I can use the flash unit in ETTL mode?

 

Thanks,

Hans

4 REPLIES 4

MikeSowsun
Respected Contributor

Inspect the hot shoe connections very carefully as switching fron ETTL to TTL is a common fault caused by poor contact with the hot shoe connections. 

Mike Sowsun
80D, 5D Mk III

Hi Mike,

 

Thank you for your feedback. 
I thoroughly cleaned the hot shoe on the camera body as well as the mount of the flash unit. I also changed the flash batteries to make sure I had full power. Unfortunately this did not resolve the issue. Since the flash works ok on my old 20d body, I am starting to think that the hot shoe on my new camera may be faulty (assuming that my old flash unit should work in ETTL mode with the RP body).

if anybody has other suggestions to solve my issue please feel free to chip in.

 

Cheers,

Hans

Hi Hans!

 

One thing I have seen with the original 580EX is that for some reason sometimes P.Fn 05 will be set to 01 instead of 00 which can prevent E-TTL shooting on cameras that have external speedlite control menus and E-TTL II functionality. Make sure P.Fn 05 is set to 00 and that you are changing flash settings through the flash interface instead of the camera menu.

hwildeboer
New Contributor
Hi Mark, just checked the settings and all P Fn ‘s were set to 0. Thanks for the support though.