Showing results for 
Show  only  | Search instead for 
Did you mean: 

Flash 600EX-RT stuck on TTL mode (ETTL not working)


The flash is working only on TTL mode, along with M, MULTI, EXT... so obviously if fires at full blast in every light situation.

When I take the flash batteries off and put them back on, I turns ETTL on,  but as soon as I press pre-focus, it swithch back to TTL and it stays even if I turn the flash off/on.  I tried to mount the flash on 3 different  5D II's, doing it either with the cameras on, and off, same for the flash, still working on TTL. I've reset  both flash and camera settings, and tried to access flash settings from the camera menu External Speedlight Control, but it says "This menu cannot be displayed. Incopatible flash or flash's power is turned off". I cleaned all the contacts, the pins in the flash shoe look OK, they are all poking out and moving up-down, the flash lock on the camera firmly.

Any thoughts?




We are sorry to hear that this occurs.  We recommend sending the flash to Canon for testing.  

You may fill out an online repair request form at the following link to setup your repair using our online service.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thank you Tim, of course I was hoping for a miracle cure....