cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EXII-RT Not Working As Slave

wowfactorfoto
Contributor

I just added to my equipment a second Canon speedlight. I already have the Canon 600EX-RT, and a week ago I purchased the Canon 600II-EXRT.

 

The original 600EXRT works perfectly fine as a slave with the Yongnuo transmitter, and I have absolutely no problems with it.

 

However the new 600II-EXRT will not connect as a slave to the transmitter. All settings are correct: Channels, ID and everything else, but I'm not getting a green light. It won't connect even when the other speedlite is shut off. The new speedlite also works perfectly fine when it's mounted on the camera.

 

The photo below shows how they are all set up. Am I missing something?

 

Any help would be greatly appreciated. 

2017-04-02 16.20.19.jpg

1 ACCEPTED SOLUTION

diverhank
Authority

I haven't heard of any problems between the Yongnuo transmitter and new Canon 600 flash but you never know.  Not sure what it means but Yongnuo does not list the 600 EX-RT II as a compatible unit...

 

If I were you I'd do the following things to eliminate all possibilities:

 

1.  Update the YN-E3-RT firmware (version 1.20 is the latest).

2.  Change group B to A or others to see if that makes a difference.

3.  Use the 600 EX-RT as master and see if the 600 II would connect as slave.  If it does then it's likely the YN-E3-RT is the culprit.

4.  Switch the YN-E3-RT to Gr mode and see if it would make any difference.

 

================================================
Diverhank's photos on Flickr

View solution in original post

6 REPLIES 6

Does Yongnuo claim that their transmitter can fire the 600EXII-RT as a slave? More to the point, how could they? Doesn't the Yongnuo transmitter predate the existence of the 600EXII-RT?

Bob
Philadelphia, Pennsylvania USA

While I hadn't considered that, the fact is that the YNE3RT is compatible with the Canon speedlite counterparts (As well as the YN600EXII-RT). Also, the technology on both the 600EX and the 600EXII are virtually the same technologically speaking. The only difference that I've found so far is that the EXII has an updated easier-to-use interface for selecting master/slave settings. Otherwise they appear to be exactly the same in all other manners of menus and appearance. 

Looking into more reviews and product pieces, the YN should work with the EXII as well. 

diverhank
Authority

I haven't heard of any problems between the Yongnuo transmitter and new Canon 600 flash but you never know.  Not sure what it means but Yongnuo does not list the 600 EX-RT II as a compatible unit...

 

If I were you I'd do the following things to eliminate all possibilities:

 

1.  Update the YN-E3-RT firmware (version 1.20 is the latest).

2.  Change group B to A or others to see if that makes a difference.

3.  Use the 600 EX-RT as master and see if the 600 II would connect as slave.  If it does then it's likely the YN-E3-RT is the culprit.

4.  Switch the YN-E3-RT to Gr mode and see if it would make any difference.

 

================================================
Diverhank's photos on Flickr

Thanks. I'll give these a try. 

Updating the firmware worked like a charm. Thanks so much for your help!

Avatar
click here to view the press release
Announcements