Showing results for 
Show  only  | Search instead for 
Did you mean: 

oneTouchL on my ImageFormula R10 scanner does not autoplay when it should


I plug in the scanner.  Windows 10 22h2 (64 bit) sees it fine.  It shows up as a USB drive.  I can see the software on the scanner (drive G on my desktop system); however, autoplay doesn't seem to work

I checked to see if Bitdefender was the problem, but the autoplay setting is just set to ask me if it should run whatever's trying to load.  I checked windows settings and turned autoplay on.  Then I disconnected and reconnected the scanner but still no autoplay of the oneTouchL software

Not sure why this is happening

My workaround was to grab a copy of all the onTouchL software files and drop it into a folder on my C: drive, and then I set a shortcut on my desktop.  So I can use the software, and the scanner per se works well, but not automatically which would be more convenient

I also checked tried using the scanner with my HP laptop, and no autorun occurs there either, despite Windows being set to allow it. 

At this point in time, I'm wondering if Windows 22H2 might be the culprit.  Anybody have any further guidance for me?






Product Expert
Product Expert


It is recommended that you call our Enterprise & Desktop Solutions Divisions at 1-800-423-2366 Monday-Friday 9:00 am to 8:00 pm ET, excluding holidays.

We apologize for any inconvenience this may cause; however, the steps needed to resolve the issue at this point, need to be provided by phone with a technician assisting you through them.

We look forward to hearing from you. 

Wouldn't it be better if the instructions for resolving this issue were published here, since there's at least one other person here with the problem . . . and maybe there are others?  You'd potentially save your company a lot of phone calls and repetitious money-eating sessions with irritated customers that way

--- Rich

Did you by chance find a solution? I am having the same problem.


No, I haven't.  I'm still using the workaround I mentioned above. Haven't had the time to dig into autoplay in depth. My theory at this point is that either autoplay is being stopped by the latest Windows 10 upgrade or my security suite (BitDefender) is somehow the culprit . . . or it may be due to something I haven't thought of yet

Have you been able to use my workaround?  Since the scanner shows up as a USB drive, you should be able to transfer copies of all the scanner files to a hard drive or SSD. Then you connect the scanner, and when it's recognized by Windows, you run the software (ontouchl.exe). When you're done with your scanning, merely close up your scanner and ontouchl will close automatically

You probably could run ontouchl directly off the scanner, but I chose to run it on my SSD, since I thought it'd run a bit faster

-- Rich