Showing results for 
Show  only  | Search instead for 
Did you mean: 

canoscan 9000F Mark II buttons don't work.


the buttons on my Canoscan 9000F Markii suddenly quite working.  The Canoscan IJ scan utility works normally, but no button works.  If I press a button, the on/off button flashes, but the scanner does not respond.  I have not tried to downlaod the driver, of which there are two possibilities.  It that is to e tried, which driver should I use?



Hi sinderso.


To help narrow down possible causes, please let me know what operating system is on the computer experiencing this problem, and if the computer is a laptop.


If you need immediate assistance with this issue, please contact us using the numbers and information at


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm having the same problem.  The buttons had stopped working periodically, but rebooting the computer fixed it.  Suddenly that doesn't work.


I just uninstalled the driver and reinstalled it [Scanner Driver mp68-win-9000fii-1_01-ea32_2] (9000F Scanner Driver Ver. 16.0.5).  This is on Windows 10 Pro (Verson 1909 (OS Build 18363.1016)).


IJ Scan still works, as do the settings for it, but not the buttons on the scanner (except on/off).  This makes scanning a lot of items slower.

On my new Win 1`1 machine, I installed the latest "optional" driver from Canon's site, and then the IJ Scan utility started working.  However, as others have complained, the buttons on the CanoScan didn't exec the IJ Scan process.  So it was a laborious process of scanning individual pages clicking the onscreen buttons.  Just recently, though, I've found if I make sure the scanner is _connected_ first, and turn it On and let it settle a few seconds and only _then_ boot the computer, the scanner's buttons worked!  So the bug apparently is, if you start the scanner when the computer is areadt running, there's some failure in the USB PNP process to make the connection?