cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

RS40 CaptionOnTouch will not load

dezignlady
Apprentice

I am on Mac OS13.2.1. I just bought this scanner as I have a ton of family photos to scan in and the flatbed is just too tedious without the feed option. The online stated it was compatible with Ventura but apparently not 13.2.1. I kept getting a message that the scanner software was corrupt. Found an earlier thread about the software not functioning with Ventura and followed the instructions. I got the software to work for one scan then kept saying the driver was missing. Will there be an update to the driver soon otherwise I need to send this back soon as "not as advertised"

3 REPLIES 3

ArthurJ
Product Expert
Product Expert

Hi,

 The security on your Mac is not trusting the software files and reports that the file is damaged, and should be moved to the trash bin. 

To resolve this you would need to reach out to Apple. They need to go in and allow the file to be installed on your MacOS. Once that is done, you will be able to install the driver and CaptureOnTouch so the scanner will work correctly.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm not sure that is correct. I did get it to install and was able to scan one image, then it quit functioning. 

shadowsports
Legend
Legend

Greetings,

Have you performed any troubleshooting steps besides determining this is a problem with Canon software?

Is the scanner connected directly to a USB port on your MAC, or are you using a USB-C adapter?

Did you install the drivers first before connecting the device (this is an important step outlined in the setup guide)

Open Apple menu > System Preferences > Printers and Scanners.

What is the scanner connection status.  Does it have a green dot, "Ready".  Is it red or yellow, not connected or communicating, etc?

When you open its properties, what driver does it say its using?

Have you opened GateKeeper and ensured its not blocking the USB connection or not allowing the CaptureOnTouch application from running?

Does CaptureOnTouch have full disk access in permissions?

Have you tried, uninstalling the device and software, disconnecting the device, restarting, reinstalling then reconnecting the device when prompted?

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements