cancel
Showing results for 
Search instead for 
Did you mean: 

Image Formula R40 Scanner, macOS Monterey 12.1 and Canon 1/24/2022 patch

tfey
Contributor

Up until 1/24/2022's software upgrade with TWAIN Driver 1/24/2022, my Image Formula R40 Scanner (S#JY306943) was performing very well on my 27' iMac powered by macOS Monterey 12.1.  But after the installation of the 1/24/2022 patch, it no longer works.  Out IT person worked with a Canon USA support person removing then trying to reinstall the scanner, but to no avail.  Supposedly the upgrade addressed issues with Monterey 12.0, but in the process it incapacitated the scanner which up until then worked perfectly on Monterey 12.1.

My question to Canon USA is how long before this situation is resolved?

Thank you for your attention to this matter. T Fey 

5 REPLIES 5

shadowsports
Elite

Greetings,

Incapacitated is right up there with "doesn't work" as far as a description goes for the behavior or issue you are receiving.

What happens:

Does the software install?

Do you receive errors?

Have you tested TWAIN capture in more than one application?

Have you tried installing the older version of the application?

We don't have much to go on here except doesn't work.  I hope that makes sense.

 

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

All good points.  I did not talk with the Canon tech so I will get answers tomorrow from our IT person who did.

Take care. Tfey

  1. Software Installs
  2. Receive Error: Unable to load driver when attempting to scan
  3. Have not tested TWAIN capture in other software
  4. So far we’ve only installed the latest CaptureOnTouch software for BigSur

 

shadowsports
Elite

Greetings,

Thats more helpful, thank you.  

Currently, there is no official support for CaptureOne under OSX12 Monterey.  The last supported version is for BigSur.  Sometimes drivers from a previously supported OS can work after an upgrade, but then stop if Apple changes something significantly.  You may need to wait for an update, as something might have changed which won't allow it to work with 12.1.x

The current TWAIN driver v1.3 lists support for OSX 11 and 12 (Apple and Intel) silicon.  This is not a patch.  

Did you update your MAC recently to Monterey?   

I'm asking because I don't see a different twain driver for OSX 11 and OSX12.

Is there a time machine back up available so you can go back to a working state until the issue can be addressed?

If you had a time machine back up, this would not be such a debilitating issue.

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

First, the Canon R40 started working tonight! Magic!  Yes I upgraded to Monterey over a month ago and no issues with the Scanner.  Regarding Time Machine, out tech person worked with Canon support and tried to install the older software but was not successful. I just checked the Canon USA site and the 1/24/2022 patch was the most recent.  It starting up again was as big a surprise as it failing.  Thank you very much, Rick, for your assistance.  I have been involved with Canon photography for a number of years in the past (30+) but this is my first experience with their scanning equipment.  Fingers crossed that it continues to function. Take care and be safe!

Announcements