Showing results for 
Show  only  | Search instead for 
Did you mean: 

CanoScan LiDE 400 "Cannot Communicate with Scanner" Error Message


I just received my new CanoScan LiDE 400 tonight. It installed with no problems, turned on with no problems...but now I'm constantly getting the error message


"Cannot communicate with scanner for these reasons: 

-Scanner is turned off.

-USB Cable is disconnected.


Please check and try again. 

Scanner driver will be closed.


Code: 2, 156, 33."


I have tried EVERY "fix it" I've found on Google and nothing is working. I've changed my computer to Power Saver battery option -- didn't work. Changed the suspension on the USB port...didn't work. Yes, I'm using a 3.0 USB port on a Dell Inspiron 17 5000 series laptop. I have Windows 10 and I think that's the #1 problem --- Windows 10.

I've installed two different drivers that's supposed to work... didn't. I've installed it via the CD-ROM, didn't work...uninstalled and re-installed via the website... didn't work. Nothing is working. 


Should I just return the scanner and go with a different brand of product? I already have trouble with my Canon MG3500 series printer so.. I should have known better than to buy a Canon portable scanner. 



Have exactly same issue. The lamp is stuck atop with 2,156,33 error. When reconnecting to PC the lamp goes down and back up again and stucks there again. Locking/unlocking multiple times doesn't help.


I too got same problem.  I visited local service center.  He advised to format my PC.  How could we format PC for scanner.  I connected scanner to another LAPTOP.  It worked good for 6 months.  Now i am facing same with LAPTOP also.  If I visit service center I am not sure if they will ask me to format my Laptop for proper working.  I never expected such a failure product from a great brand like CANON.


I believe I found a workaround of the scan header position issue. As most of us here, my LIDE 400 randomly move the scan header to the back end position (where the USB port is) instead of to the front (where buttons are) after connection. It is quite random, nothing to do with which USB port is used from my laptop, or if the cover is open or closed, etc.

I read the post from someone from Canon Expert that the solution is toggle the Lock button several times and retry, giving some credit to this expert but that's not the solution (or it is only part of the solution). But this help me to understand this has something to do with the toggle.

After examining how the mechanic is designed, I understand the toggle is actually the source of the issue. It doesn't have the require precision to make the scan header "understand" that it is in "Unlocked" position.

So the workaround is quite simple (but still not very practical). when you connect the scanner to your computer, immediately push the toggle to the right side with force. This will ensure the scan header remain to the front side. And that's it.

Enter for a chance to win