Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Vixia HG21


I bought that cam around 2011. I've transfered files to my computer with ImageMixer 3 SE Player Ver.3 back then with no problem. I've stopped using the cam for a few years and I decide to re-using it recently. Today I'm running Windows 7 Ultimate and when I try to transfer my recent videos to my PC using that old sofware via USB, Window detected the removable disk (I can see it in my computer) but ImageMixer tells me that there are no files on the camcorder. I've tried to upgrade everything I could but still doesn't work. Now my new videos (and old ones) are stuck on the camcorder and can't transfer them. Can somebody help me please? I'm kinda discouraged and don't know what to do anymore. Help me please. Thank you



You say Windows recognizes the camcorder as an external drive.   Have you gone into Windows Explorer to view the contents of the drive (camcorder)?  If not, try it and open the various folders until you find your video files.  You should be able to copy the files from the camcorder to the computer simply by doing a copy and paste.  


If you are able to do this, and considering the age of the camcorder, I recommend you backup those videos as soon as possible.  

Thank you for your reply.I insert some images, hope it means something to you. This is what I see after connecting the USB cable and power up the cam. It's been detected but not completly....I don't know.... Here are the 4 pics1 Device manager.jpg2 Imagemixer 3.jpg3 Save files to PC.jpg4 Computer.jpg

Thank you for the screen shots.


I see the dilema.  It looks like it is showing as 2 drives in device manger but only as one in Windows Explorer.  In Windows Explorer it looks as though there is nothing on the drive (Canon E: 7.50 GB free of 7.50 GB).  Drive E: is probably showing an 8 GB SD card.  Do you have an SD card inserted in the camcorder?


What do you see if you go into Disk Management?  If the ImageMixer 3 software is reporting on the right drive (camcorder's internal drive) then it appears as though there is nothing on the drive.  I can't say for sure whether or not it is reporting on the correct drive.  In Disk Management both of the camcorder's drives may appear and if so then you would able to tell more from that than anything reviewed thus far.

Yes I do have a SD card in the cam (8GB) It seems that it detect only the SD card, not the hard drive on the cam. I have 31 GB of videos on the cam.(They are all there when I power up the cam without the USB plugged in)5 Disk management.jpg. Here's a snapshot of the disk management

You said you upgraded what you could.  Did that include ImageMixer to version 3.1.4?

Have you visited the Canon Support page for the Canon VIXIA HG21 for software downloads?  After looking more closely at the offerings I'm not sure that will help.


Have you tried any other video capture software to see if the camcorder can be detected?

I have the version 3.2.4 of ImageMixer. I've tried Cyberlink Power Director 15 and all you see is that SD card as drive E. I'm on the palyback icon (blue Icon on the cam) and all that the PC detected is the SD card. I can play all the videos on the camcorder screen and even on my TV with a HDMI cable but for whatever the reason, the PC detects only the SD card as a drive. If I remove that card and try to connect via USB cable, it tells me to re-insert the card in the cam. Very bizarre !!! I communicate with Canon support by email and they don't understand either. They gave me the # number and I'll call them soon. I have a very modern PC and never had troubles with anything else. Why does the USB connection detect the SD card instead of the camcorder hard drive ??? 3 years ago I didn't have any problem extracting the files. Is it because of the x64 bits system?

Even after talking to a Canon representative, nobody seems to know what's goin' on. Because the PC detects the SD card and not the HDD, I copied the files from the HDD to the SD card so I could finally extracted the videos from the card to my PC. It's a pain in the ass and takes lots of time but it worked. Thank you very much for your help

You're welcome.  It really is bizarre.  Understandable if the HDD were fautty or the USB port was bad but since neither is the case that makes it all the more puzzling.  Just out of curiosity, have you tried it on a different computer?  If yes, same results?

I would have loved to try it on another computer but there's nobody around here with a PC. They all have, like 90% of the population, these smart phones. I found a workaround for my problem but I didn't find an answer to my question. The Canon guy said to me, after I transfered the files from the SD card to re-format the HDD on the cam and see if it does the same thing with new videos. That's what I did and I got the same result. Like you said, very bizarre...