cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Aperture flicker on C70 with older Sigma 50mm f/1.4 and .71 EF to RF adapter

Gabevanlelyveld
Apprentice

Hi there,

I have the Canon C70 (latest firmware) with the Canon .71X RF to EF adapter and a Sigma DG HSM 50mm f/1.4 lens (not the newer Art version). Every once in a while the aperture will start to flicker and there is no way to make it stop except to turn of the camera. I don't know what is causing it. Lens and camera compatibility? Lens and camera plus adapter compatibility? Lens failing? Something else? To be clear, it is a manual flickering that I can see on the screen and hear happening, not the kind of flickering that comes from setting the wrong shutter speed under certain lighting conditions.

Any thoughts are very much appreciated. Thanks in advance.

-Gabe

7 REPLIES 7

mollybrown789
Apprentice

I have a canon EOS C70, it's intermittently having these issues. Another acquaintance is having the same problem, and I found your issue online too. Looks like you are not alone!

Basically what happens is you'll notice the screen begins to flicker/flash, (when not recording) and it almost looks like the shutter speed is wrong and picking up artificial lighting poorly, (but that isn't the issue) and if you go to try and alter a setting or record, the camera won't respond, so you are forced to turn it off. When you try to turn the camera back on, it wont restart, almost like it's a computer crashing. We have found the only temporary fix is to remove the battery and replace it. So far, for both of us this has allowed us to continue filming as we were, hope this helps you too. 

We havent noticed that it's audible to the user, but we haven't been in quiet environments and naturally when the issue occurs during filming we are panicking and trying to get it to stop quickly so we can continue filming so are not concentrating on this I guess. Interestingly, we both have the 50mm sigma f1.4 Art lens and have been using these, I am not sure if it's always happened with this lens attached but I will try to make notes of the exact circumstances in which it happens to look for patterns. 

It's happened to both cameras (mine and the other persons) several times, it happened twice in one day to me on Saturday. It's interesting though because the cameras are very similar in age but their camera has the new firmware and mine isn't updated and their camera has seen much more use than mine. But the issue began happening within the same few weeks for both of us. 

Have you had this issue for long, how often is it recurring etc?

PS. I contacted Canon CPS today on +44 (0) 800 9150009 and spoke to a guy called Gavin who said he would be investigating it. Have you contacted them, if not, then it would be a good idea so you can get his feedback too.

Gabevanlelyveld
Apprentice

Thank you, mollybrown789. That all sounds very similar to my issue. Curiously, I have since upgraded to the Sigma 50mm f/1.4 ART and I haven't had the same issue. There was one time that the flickering effect appeared in my footage withing Adobe Premiere Pro but not while I was shooting. It also didn't appear while playing back in camera or in a standalone video player on the computer. I then changed a setting (can't remember which) inside Premiere and it went away. I'm hopefully that means this problem is in the past but no 100% sure. If you come across any follow-up info that might be useful please do let me know. Thanks again!

mollybrown789
Apprentice

Hi Again, 
Oh that's interesting, I actually already have the Sigma 50mm f/1.4 DG HSM ART, Canon EF Fit lens.... still getting the issue! I was getting it a few times a day and then I had a shoot on sunday when I decided not to use the 50mm lens at all and I didnt come across the issue. Very interesting! 

Have you updated the c70 firmware since purchasing? (I havent yet, I wonder if that would help)

I haven't got any further updates to this as of yet but will let you know if I do! Ditto to you 🙂 


I did update the firmware for the camera as well as the adapter. 😀

ahh ok, is this after you got the error?

I may need to do this if so! 

Yes. Like I said, I haven't had the problem with the news lens since the firmware update but I did have the weird thing where it showed up in my footage in Premiere but wasn't actually there. I can't remember if I reset my preferences or cleared my cache or what, but whatever I did it fixed it and I haven't had any issues since. Good luck!

Hi again. Thanks, I will give that a try! 

 

Thanks

Molly

 

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.