cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5c aperture fluctuates in video mode

cwilson
Contributor

This just started happening recently:

Using a canon RF>EF adapter (we've tried both the regular one, and the ND one) in video mode the camera will occasionally not be able to keep the lens in any aperture other than all the way open. If you try and close it down it repeatedly cycles between wide open and your desired aperture, constantly opening and closing the blades.

I've tried restarting the camera, pulling the battery, multiple canon EF lenses, different RF>EF adapters, and I've updated to the latest firmware. I can't test with an RF lens because I don't have one (but having it happen with multiple adapters and lenses tells me its probably the camera body at fault).

I've attached a video to demonstrate the issue. 

11 REPLIES 11

shadowsports
Legend
Legend

Greetings,

Can you provide more details about your settings please?

Are you using Iris Mode: Manual or Auto?  If you are in Auto, the camera will be in a constant state of correction.  

I only have an RF lens with me.  Iris Mode: Manual.  My mode dial runs through the lenses range f2.8~22 and holds where I stop.

I have a Canon Control Ring too, but won't have access to it and an EF lens until tonight.  Review your settings, it might be something you've over looked.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Thanks for the response.

Everything is kept in manual. 

Waddizzle
Legend
Legend

What lens are you using?

Not all lenses that are great for photography are great for video.  In most cases, it is because the lenses have loud apertures, which the mirror slap typically drowns out when capturing photos.

Also, the apertures on many EF lenses do not smoothly transition from one Av setting to the next.  The behavior is similar to having an aperture ring with click stops.  The aperture “jumps” from one setting to the next.

Cinema lenses tend to have “declicked” aperture control, which allows smooth “fade to black” transitions.  It also allows for smooth and silent exposure control during other scenarios.

Again, what lens are you using?  

--------------------------------------------------------
"The right mouse button is your friend."

The lens in the video appears to be the 50mm f/1.2 L

From what the OP describes though, as well as the video, I would not expect the lens to switch rapidly between f/1.2 and say f/2.8 or f/4 (the target aperture).

Unless you can borrow/rent other EF or RF lenses, I'd send the unit in for service (along with the adapter, since that could be the part with the fault).

I just tested my EF 50mm f/1.2 L lens connected to my EOS C70 via the 0.71x adapter.  It is able to hold the aperture at whatever I set it to.  It does not constantly toggle between between the widest (f/0.9 in this case) or what I've set the aperture to (e.g. f/4).

If this was regarding the smooth transition between two aperture values, I agree that cinema-style lenses would be required.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Thank you for responding.

You are correct in your analysis of my question and problem. Unfortunately I've also tried multiple adapters (we have several, all canon) and it doesn't seem to fix the issue. You might be right that it needs to be sent in for service.

Thanks for the response.

The lens is the 50mm 1.2, but the camera does this with any canon lens. Yes I could use cinema lenses, which I have some, but some of the people using this camera require auto-focus, and the Canon lenses are great for that. The clicking between apertures isn't the problem, it always does that, the problem is that it can't *keep* any aperture other than wide open. 

shadowsports
Legend
Legend

Tested with the control Ring and EF 70~300 USM II.  Aperture moves through range and holds where I stop clicking.  the main dial.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Thanks for testing. Yes the EF lenses I have had been working just fine until a recent shoot, when this issue popped up.

baileyd
Apprentice

Wanting to bump this topic - I have just started having the exact same issue with a sigma 24-70mm f/2.8 dg os hsm art lens for canon and the EF-EOS R adapter. The lens and aperture control works perfectly fine in photography mode. 

Spoke to Canon and they are requiring unit to be sent in for assessment - did you have any chance fixing yourself?

Avatar
click here to view the press release
Announcements