cancel
Showing results for 
Search instead for 
Did you mean: 

New Pixma Pro

nancyr84
Occasional Contributor

I have a IMac computer and recently purchased the Canon Pro 100 printer. I am totally underwhelmed by the print quality. I am going to calibrate my screen as soon as my Spyder comes. I also have been trying to download the Canon plug in to use with photoshop. It is telling me my version is not compatible. It’s a relatively new version of photoshop and Lightroom. What’s up? 

3 REPLIES 3

Welcome Nancy. A couple of questions.

 

1. Do you have the Canon IJ series driver installed? Go to System preference->Printers & Scanners and look. You do not want a driver that says AirPrint or Bonjour.

 

2. What versions of macOS, PhotoShop and Print Studio Pro?

 

3. To install PSP, go into Applications->Canon Utilities->Print Studio pro and run the Plug-in Installer. It will ask about LR (unless you don't have LR). Select "Next" Select Photoshop and click "Browse" Browse to App, find Adobe Photoshop, select the Plug-ins folder and select Open Select "Next" It should install.

 

 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

nancyr84
Occasional Contributor
When I try this it quickly says it is installed although it never installed it. I have 2019 photoshop. No AirPrint etc. I’m getting frustrated!

I have verified that PSP is installed for both LR and PS on my MacBook. If I rerun the installer it never says it is already installed. Are you sure you are running the Plugin Installer (which is in the PSP folder in Applications) and not the PSP installer?

 

I'm on my PC right now. I will go to my MacBook and post a screenshot.

 

Here is what you should be looking for:

 

Screenshot 2018-11-19 10.13.10.jpg

 

 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic