cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon imagePROGRAF PRO-300 compatibility with macOS Sierra, Version 10.12.6

canon-comm-01
Apprentice

I recently purchased the Canon imagePROGRAF PRO-300. From the reviews I've read the printer gets good ratings. I intended to use it with my iMac, running the macOS Sierra, Version 10.12.6 operating system. In the Mac OS systems shown on Canon's website Sierra is not listed. Does anyone know if the Sierra OS I'm running is compatible with the PRO-300?

2 ACCEPTED SOLUTIONS

ArthurJ
Product Expert
Product Expert

Hi,

The PRO-300 is compatible with your operating system and the drivers and software can be found HERE. Once the page opens, select software and drivers. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post

AlanGMather
Apprentice

I'm running my PRO-300 on High Sierra. OS 10.13.6. Why not update to High Sierra. My Mac is a 2011 27" iMac. One of the best Macs ever made!

View solution in original post

4 REPLIES 4

ArthurJ
Product Expert
Product Expert

Hi,

The PRO-300 is compatible with your operating system and the drivers and software can be found HERE. Once the page opens, select software and drivers. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thank you Arthur.  I'll go ahead & unpack my PRO-300!

AlanGMather
Apprentice

I'm running my PRO-300 on High Sierra. OS 10.13.6. Why not update to High Sierra. My Mac is a 2011 27" iMac. One of the best Macs ever made!

Thank you Alan. I'll look into that. Ready to install my PRO-300!

Avatar
click here to view the press release
Announcements