cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imagePROGRAF iPF670e & iPF760 ink light, maintenance cartridge, ink sponge errors

Lahearle
Contributor

Hi, I own both a canon IPF670e and a ipf760, both are throwing errors and I wanted to get more information on this.

Please don't refer me to maintenance pros, I want real answers. I can fix any Mobo/electrical issue myself, I don't need to pay a guy 800 dollars to do a half job.

 

So the 670e is having an issue with the ink light. It powers on, feeds the paper, then asks me to open the ink cover and refill the ink. All the red lights are on except for the Mblack in the middle on the right side. I tried reconnecting, lightly moving it, nothing at all. So I tried connecting a regular black cartridge, nothing at all. Has to either be the detector in the printer or a connection on the mobo. Not sure how to remove the housing for the black ink and can't find a video. Anyone know where to find one?

 

the 760 has two errors in the log, one for maintenance cartridge change, and one for the ink sponges being full. Easy fix, but wondering if anyone has any nightmare stories about this so I can avoid problems?

 

Also wondering if there is a document online or video that shows a full parting out of these models. one or the other will do as they are nearly identical. I just want a full part description or full part out video, think "lego manual"

Any information is much appreciated. If a Canon rep has any info on these manuals or a source to buy replacement parts like the sensor, that would be useful as well.

4 REPLIES 4

Lahearle
Contributor

EDIT: 

I FIXED THE 760, no problem with it now.

After booting into service mode with the 670e it is throwing a insert maintenance cart error, rinserted it multiple times, still does not recognize its in/and/or that the maintenance door is closed.

Lahearle
Contributor

Also edit update:

tried the 760 cartridge, did not work in the 670e either. 

either its not recognizing the cartridge or the sensor is out. I found aliexpress cartridge sensors for 4 dollars (pack of 5) so assuming this is a fairly common problem. Since gameboy cartridges are superior in quality.

If anyone has any info on this much appreciated.

Lahearle
Contributor

Okay so I took the left Mblck and put it into the center (one that was not working) and the light came on indicating it is not the machine itself. When it gave me the maintenance tank I had previously removed it so maybe it did not register since I had already powered into service mode. I resat it and repowered back into service mode, no problems. I am however missing a mblck ink cart as the sensor was broken out of it so it likely was damaged in insertion by a user (not me) but the internal sensor works fine with the other cartridge and detects its level. MEANING that if I can replace the other cartridge and reset it in service mode, it will likely work fine as everything else is pristine. Easy fix.

Thanks for all your help forums (lol)

shadowsports
Legend
Legend

Greetings,

It sounds like you have everything figured out.  In case it doesn't go as planned, Canon Support is available.

Support:

1 (800) 652-2666

They have a great parts dept. too:

Canon Parts Dept
Canon Parts Order Desk at (866) 481-2569
Weekdays from 9 AM - 7 PM, ET.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It
Avatar
click here to view the press release
Announcements