Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Ipf6000s wont listen to my mac Monterey


After my canon ipf510 stopped working, i bought a canon ipf6000s. There seems to be no driver for mac after snow leopard for this printer and this makes me very frustrated. How can i work around this? I would like to be able to use it. I was somehow able to install it but when i do, i get the message filter failed and it wont print. I de-installed it following these steps but when i try to re-install it i get this message; The software for the printer was installed incorrectly. Please reinstall the software from the manufacturer.                                  I also tried a really old mac but cant get to the point when the printer starts to print with it and would prefer to be able to use my computer for this.

Does anyone have a good idea to make this work?




Thanks for posting!

While our Forum Community members are welcome to chime in, the imagePROGRAF iPF6000S has been retired. That means we do not offer support for the printer or updated drivers. We recommend updating to a more modern printer and reaching out to our Canon Upgrade Program specialist who will go over the best options for upgrading your printer. They can be reached at 866-443-8002.

I get that its old, but it works fine (with a pc, im a mac-user) so i would like to be able to use it. I just bought it and cant afford another one.



The 6000s uses USB or ethernet for communication.  If you are using a network connection, you'll need to ensure both devices are connected and communicating on the network.

If you are using USB, then a proper USB cable that interfaces correctly on the MAC is required.  Using adapters, hubs, etc can cause communication issues.

The printer is supported under OSX Monterey.  Drivers can be found here:

Canon Support for imagePROGRAF PRO-6000S | Canon U.S.A., Inc.


As far as us solving a communication or software issue for you through a forum, that might be difficult since we are not there to see the issue or challenges you are facing.  

I would start over, removing any previous installation attempt(s) which failed.  I'd also remove the printer from Apple Menu > System Preferences > Printer and Scanners applet.  If no other printers are installed, resetting the printing applet might also be recommended.

If you are not familiar with these steps, you may want to consider getting assistance or help from an IT professional.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you, this made me very hopeful. I went trough all the steps and everything looks better, the icon of the printer is exactly how my printer looks, when i print the printer makes a sound as if it understand its supposed to start, i still get the Filter failed message, could it be the cable since i need an adapter from usb to usb-c? If i buy a printer to usb-c-cable perhaps it will communicate better?



Good Morning,

I cannot promise this is going to help you because as I said earlier, we aren't there to see your set up or connection type.  The Filter Failed Error is a communication issue.  Possibly from the USB cable or a remnant of older software from a previous software or OS upgrade.  You should try to use a standard USB cable to a standard port if possible.   

These steps are provided by Canon, but I cannot say with certainty they will help.  

1. Click on the Apple in the upper left hand corner and then System Preferences.

2. Click on Printers & Scanners.

3. Click on the Canon printer on the left side and then the [-] at the bottom to remove it.

4. Repeat until all Canon printers are removed and then close System Preferences.

5. Click once on desktop so Finder appears in upper left corner.

6. Click on Go and then Go to Folder.

7. In that box, type /Library/Printers/ and click Go

8. In the folder that appears, please delete Canon folder.

9. Click on Go and then Go to Folder.

10. In that box, type /Library/Printers/PPDs/Contents/Resouces/ and click Go

11. In the folder that appears, please delete all files that begin with Canon and all files that begin with CN.

I hope this helps. 😀

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you for your help, i tried all of this now. Will also try to buy a usb that goes to usb-c, since the adapter may be a problem.

By the way, this is the printer i own: 

Screenshot 2023-03-31 at 09.25.48.png

The one with the driver for monterey seems to be this one: 

Screenshot 2023-03-31 at 09.19.43.png