Showing results for 
Show  only  | Search instead for 
Did you mean: 

new wifi not connecting to ts8120


I have a TS8120 and have a new wifi router. my printer sees it but 'fails to connect' I've rebooted router, printer and tried to download new drivers but don't seem to be able to do so.  I'm willing to buy some support, but, seem to be in a loop trying to get a support page where maybe someone could chat with me. I have fairly new Lenovo laptop, win 11 and am connected to TMobile 56 wifi just fine.  Router is about 15 feet away so shouldn't be a problem. Would appreciate any suggestions or directions..

Thanks All,





Hi Robbsey,

I don't think buying support is necessary here.

The TS8120 has a 2.4Ghz radio and is only capable of connecting to a 2.4 Ghz wireless broadcast.  WPA2 and AES Encryption standard.

Tell me more about the new router.  Its sounds like T-Mobile.  Is it a 5G only router or does it have a 2.4Ghz band?


Use a separate SSID name for each broadcast



If the router is set to operate in WPA3 encryption the printer does not support this standard.  See if a WPA3/WPA2, or WPA2 only setting exists.  WPA2 is very secure so don't worry.    

If you want to keep the same SSID name for all bands, you can try temporarily disabling the 5G broadcast to connect, then re-enable once successful.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you so much..yes it is a new T-Mobile Gateway  Model TMO-G4AR and I suspect it is 5G only or maybe inclusive to 2.4 ?  Anyway, it makes sense what you wrote.  I do see that TMOBILE does not use WPA so somehow I have to configure it for the TS8120.  I'm kind of lost when it comes to setting up an SSID name, though perhaps I can find that , maybe on TMOBILE site...or is that Canon..I'm not sure...but, I'll try to follow up on your (and the other suggestions).  Really appreciate any help...I also know I can look for a local Canon retailer and maybe get some help..

Much appreciated,




I have seen Tmobile routers use WPA3 encryption and if the TMobile device they gave you is running WPA3, then you wont be able to connect the printer or get to the password screen during Standard Setup. 

You can change this setting on the Tmobile app or you can reach out to TMobile and have them change their device settings to WPA2 and then try using the standard setup to connect the printer. At this point your network will appear and you will be able to enter your password and connect the printer. 

Once the printer is connected to your network, you have set the TMobile device back to WPA3. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


If you're on T-Mobile Home Internet, you may need to separate your WiFi bands. You'll find that info on their site HERE.

Then, try the wizard from THIS SITE. It will re-install the newest version of the software. 

Thank you Stephen; yes it is T-Mobile Home internet and I'm having trouble finding the right info on the first link you sent.  I'll keep looking.  The second took me to Win 10-S mode,  I have Win 11.  I think that this direction is the way to go but not clear yet how to add the correct info to get it connected.  I will keep looking.  The model of the Gateway is TMO-G4AR.

Thanks so much for the reply..and any follow up thoughts are welcome.




Hi, Robbsey.

Does your router have a WPS (Wi-Fi Protected Setup) button on it? I just connected an ancient Canon Pixma MX492 to my home network, served by a somewhat LESS ancient Asus RT-A66U router (that DOES) have the button on simply holding the button down for 10 or 15 seconds at the suggested time during the "connection process" (as described on the Canon website) and things went gloriously. At least it SEAMED that way. In honesty, though, I haven't tried printing wirelessly, because I have no need to print from throughout the house or from my cellphone......or smartwatch!
Re the comment someone else made about your router possibly being 5G only....I would think that would be "not likely". But, hey, what do I know. Good luck.

Thanks everyone;  I have identified one problem which is creating a 2/4 G wifi site. which I did through Tmobile. Now, I need to put in the NEW password on the Canon TS8120. But, I cannot get to the screen to reset the password.  I've been overl the tutorials and steps right up to the step before showing me the change password screen...but, it won't take me there.  I'd love to connect with someone live with Canon, but, cannot get to that option, even.  I feel pretty close and pretty stuck. 

If anyone has a suggestion, I'd appreciate it.


Robert S.