cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS LBP6000 - Mac Sonoma 10.14 - Printer Stuck on Sending Data to Printer

griffey244230
Apprentice

Just updated to Mac Sonoma and of course the Canon Printer I use won't function properly.

Specifically I download and install the latest driver from Canon (10.0.7 as of today), delete the old instance of my printer, add a new printer. But when I go to print, it gets hung up at "SENDING DATA TO PRINTER". Nothing else happens. It just hangs. 

Various installs, uninstalls and restarts later, nothing has changed. 

I then try to my Ventura Mac having seen the printer work on it previously... and now it too won't work. Wash, rinse, repeat -- no better, same Sending Data to Printer.

I jump on a Big Sur machine... and I load up the driver, go to print and it's instant, just like old days. 

So what's the issue here? Is this a Canon Driver issue? Apple rushing updates issue? Or have I made a fatal error that I haven't deduced yet? 

Wanted to get this out there cause no one seems to address the SENDING DATA TO PRINTER issue anywhere on the internet. Feels like there should be some threads to folks work through the issue. 

(just tried once more and yeah, stuck at the same spot)

8 REPLIES 8

Danny
Moderator
Moderator

Thanks for joining the conversation, griffey244230!

So that the Community can help you better, we need to know exactly which Canon printer model you're using.  While we haven't released a printer with the model number "LBP600," we have produced a series of printers within that model number range.  You'll find your printer's exact model number on the front of the unit at the lower right.  If you could That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Sorry about that, left off the 0 -- Canon LBP-6000 is the printer in question 

I am having the same problem. Was this issue fixed?

I am having the same problem. Was this issue fixed?

I have not had any luck on Ventura or Sonoma.

Still works amazingly on Big Sur, albeit it being a hassle to use a different machine. 

Same problem, same printer. We need the new drivers for Sonoma, thanks!

sandbox
Apprentice

Sonoma macOS has been out since September. Is this planned obsolescence on Canon's part??? I'm also having this issue of "Sending Data to Printer" being hung up. Currently on Sonoma 14.3. I've installed the new Sonoma driver several times. Still hung up. Please fix this asap. My printer works just fine on my other mac running Ventura 13.4 and I'd like to avoid it going to the dump when it still has plenty of life in it.

Totally agree!! Or maybe Canon is a Company that does not support environment preservation? (Other than client...)

Avatar
click here to view the press release
Announcements