cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless on MG3620 - light shows it has a connection but I cannot find it on any network

NCguy
Apprentice

I have set up the Pixma MG3620 but I cannot set up the wireless printing.  The light is on and shows it connected to a network but I cannot find which one (I needed a small unit and this one doesn't have a screen).  I followed the directions but holding down the wireless button to get the power button blinking does not work.  I have held it down multiple times, each time for over 15 seconds.  I am at a loss.  Is there a way to find it?  Should I buy a USB to USB cord and try to set it up connected? I don't want the wire.

 

Thanks for the help....

10 REPLIES 10

Patrick
Product Expert
Product Expert

Hi NCguy,

 

Do you have a smartphone or tablet?  If so, try downloading the Canon PRINT Inkjet/SELPHY app from the Google Play Store or iTunes and using that app to connect your PIXMA MG3620 to your wireless network.  Once it is connected, try setting it up on your computer again.

 

If you continue to have difficulties, please contact our support group using the following link:

http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Patrick, I am having the same problem here. When following these steps, it ultimately leads to the same step: hold down the wi-fi button and the on button will flash.  The on button will not flash!  What should we do if the light does not flash?  Everything up to this step was smooth sailing.  Yes, my printer is on.

i have the same issue but its not working. i tried each step and still wifi button is flashing but my macbook cant find printer and my iphone also cant find printer. its frustrating me .

Tallind
Apprentice
I am having the same issue, and it is becoming quite frustrating. I've also seen mention of doing a factory reset by holding down the power button until the light flashes 17 times, but I can't even get it to flash once. It almost seems like the printer either recognize's only button presses and not holds, or the light simply doesn't flash. However, with that in mind, I did try holding the WiFi button for about a minute and then doing the other steps without the flashing on light, but that just caused orange lights to activate and it did not sound like it was doing what I had intended so I pressed stop and then turned off the printer. I have also tried connecting via the android app, but it remains "waiting for a connection to the network starting with [Canon_ij_]" for what seems like eternity (I left it open for 10 or 15 minutes using each method: automatic, LAN, and direct connection).

Same here, let me know if you found a solution.

 

Thanks

Hawk69
Apprentice

I fixed it. I hope it works for you also:

- First, ensure not more than 1 wireless router is turned on to eliminate confusion.

- Ensure your computer or smartphone is on the same network that you want the printer to connect through.

- I logged onto my router settings (192.168.0.1) and I manually added the printer's MAC address.

- I then pressed the wifi button with the constant blue light on, until the ON button started flashing.

- Pressed the Color button once, then the wifi button once, then the wifi light started flashing.

- My smartphone Canon app found the printer right away and I completed the setup.

 

Goodluck all..

marshdan
Apprentice

I just had a very similar issue.

 

Turns out that in order to setup the device to use the scan functionality you must first insert ink cartridges. o_O

 

Dear Bob,

Thank you for contacting Canon product support. I'd be happy to assist you with your PIXMA MG3620.

You indicated that holding down the wifi button on the printer does not cause the power light to flash. So that I can better assess your situation, I'd like to ask a few questions.

1. Have you installed both ink tanks?
2. Is the orange alarm light on the printer flashing? If so, how many times?

We look forward to your response with the requested information.

Please let us know if we can be of any further assistance.
Thank you for choosing Canon.
Sincerely,

Pretty crazy I know. But it did work.

 

Maybe this won't be a "feature" on future models...

Same problem - and same solution - with the MG3650.  Ink cartridges installed and all works.  But not without difficulties.  WPS finally solved the rest.

Jacgalaxy
Apprentice
Make sure the exit tray is closed..that's what worked for me..idk why
Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x