cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Two Mac Book Pros Neither Can See Pixma G620 Scanner

sasafrass
Apprentice

I have two Mac Book Pros, one running Big Sur v.11.6.6 and an older one running High Sierra v.10.13.6. Both are on the same network and both see and can print wirelessly on my printer, a new Pixma G620. My problem is that I can't get the scanner to work with either computer. When I open and try to scan from the IJ Scan Utility Lite program, neither computer lists my printer at the top of the dialog box and when I open printers and scanners in system preferences, highlight my printer, Scan and then click on Open Scanner, I get A "failed to open a connection to the device (-21345)" message on the newer MacBook Pro and "An error occurred while communicating with the scanner (-9923)" message on the older computer. The printer is turned on and I have run the setup program several times on both computers and have downloaded and run the standalone IJ Scan Utility Lite program from the Canon Pixma G620  product page on both both computers with no luck and I an at a complete loss as to what to do next.

1 ACCEPTED SOLUTION

Patrick
Product Expert
Product Expert

Hi sasafrass,

To resolve this issue, please follow these steps:

1.  Please press the wrench and screwdriver button on your printer 1 time

2.  Use the right arrow to select Device Settings and press OK

3.  Use the right arrow to select LAN settings and press OK

4.  Select Wi-Fi and press OK

5.  Use the right arrow to select Manual setup and press OK

6.  Use the right arrow to select TCP/IP settings and press OK

7.  Use the right arrow to select IPv6 and press OK

8.  Press OK on the displayed message

9.  Press OK on Enable/disable IPv6

10. Use the right arrow to select Disable and press OK

Once Disabled, please attempt to scan.

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post

2 REPLIES 2

Patrick
Product Expert
Product Expert

Hi sasafrass,

To resolve this issue, please follow these steps:

1.  Please press the wrench and screwdriver button on your printer 1 time

2.  Use the right arrow to select Device Settings and press OK

3.  Use the right arrow to select LAN settings and press OK

4.  Select Wi-Fi and press OK

5.  Use the right arrow to select Manual setup and press OK

6.  Use the right arrow to select TCP/IP settings and press OK

7.  Use the right arrow to select IPv6 and press OK

8.  Press OK on the displayed message

9.  Press OK on Enable/disable IPv6

10. Use the right arrow to select Disable and press OK

Once Disabled, please attempt to scan.

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

sasafrass
Apprentice

Patrick, you have ended many hours of total frustration for me. I can't thank you enough for your assistance. You deserve a pay raise or a commendation at the very least. Thank You!!!

Avatar
click here to view the gallery
Announcements