Showing results for 
Show  only  | Search instead for 
Did you mean: 

TS 9020 starlink issue


My TS 9020 has worked flawlessly on my old dsl modem/router.

I just moved the printer to my new starlink network. When I use the manual input and select the network name and enter the password everything works fine for several hours. After which I can not find the ts 9020 as a wireless printer on a iphone or mac attached to the starlink network.

If, on the printer, I select "deactivate LAN" and then "activate LAN" it will work again for several hours.

Printer firmware is 2.040.

I have the new starlink router that does not have a physical ethernet port. I have ordered their optional ethernet adapter.

I will appreciate any suggestions.



Based on your description, this is what I believe is happening.

The IP address of the printer is changing after some period of inactivity.  Disabling / re-enabling the network interface forces the printer to query the router for a new IP.  Once reconnected, priting resumes until the behavior repeats.


Assign a static IP to the printer that doesn't change.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thanks for your reply Rick.

The starlink router doe not appear to be accessible via http or telnet.

I will reach out to starlink support to see if there is a way to add a static ip for the printer.

The canon install instructions give several methods. I will give some attention to them.

John Bostock

Hi.  I have a similar issue.  I switched to Starlink a while back and have a C250iF printer connected via ethernet.  I did get the printer working by clearing the existing settings and rebooting it.  The printer was able to integrate the Starlink settings.  After that the printer printed from all our devices, but it would no longer scan and send to email.   I tried resetting the DNS which didn't work and had to reset again.  Any thoughts will be appreciated!