Showing results for 
Show  only  | Search instead for 
Did you mean: 

Printer Software on Canon USA Website is NOT current version!


Hi.   I posted the response below in the Print Studio Pro - Problem Starting from Lightroom conversation.   After consideration, I realized that I was taking the thread off-topic, and the information I found should be shown to all forum members.  

My original issue was having PPL "Find" my new Pro-300 printer.    It turns out that the issue is bigger and is caused by the Canon USA website not being kept up to date.    My issue is now resolved, but other members may have similar issues.    So I hope this helps them.

Best regards,




Thanks again for the great feedback.  The problem is resolved!

This morning, a Canon support rep and I discussed the situation.  He noticed that I had V1.0 installed (mP2L-mac-1_0_0-ea10_3.dmg).   He found the latest 1.3 version (mP2L-mac-1_3_0-ea10_3.dmg).   After installing V1.3, it worked perfectly!   Problem solved...  Sort of.

The Mac file downloaded from the PPL US software website ( is V1.0!!!  I'm notifying them in a few minutes.  There may be other locations to download the latest PPL software, but the only one I could find is

But wait, there is more fun!   The version of the Media Creation Tool that I downloaded from the Canon USA website was V7.03 (MCT-MacX-703.dmg).  However, the latest version appears to be V7.1 (MCT-MacX-710.dmg).   I just downloaded this from the Canon Canada website ( 

If you are using Canon software, I strongly urge you to check the version and then Google it to see if there is a newer version!

Best regards,