cancel
Showing results for 
Search instead for 
Did you mean: 

Pixma TS3122 and Comcast xFi

Manfred33
Apprentice

So have had a Pixma T3122 since about 2019, recently having switched from HP printers.  Boy that was a mistake! The thing has been problematic from the get-go, keeping it connected to my home network and being able to use it from any of our devices...  I had my own dual-band router and an extender and it mostly worked fine. Smiley Frustrated Now, I have an xFi router from Comcast and it is also dual-band, however the 2 bands are combined into 1 network name(SSID) so you do not see which one you are connecting to, 2.4ghz or 5.  Printer still worked after the router was installed and set up, but it became even more squirrely...would really have to mess around with it to get something to print.  Called and talked to Canon support Smiley Frustrated and we tried to set the printer up again and now it is totally jacked up, a paperweight basically, because now it will not connect to the network at all!  Is there any work around to this??  I can't believe that I can't get this stupid printer connected at all now, it's ridiculous! I should also add, that we tried this using my Android device with the Canon app and I also attempted to do it on my own through my Macbook Pro...


Thanks

2 REPLIES 2

shadowsports
Elite

Greetings,

This sounds like an issue with your router, not your printer.  I'd recommend disabling the "SMART Connect" single SSID feature for both bands (on the rouer), at least temporarily while troubleshooting.

 

Then get the priter, connected and associated with the 2.4Ghz broadcast which is the only radio it can connect to anyway.  At that point, you can try re-enabling the single SSID broadcast and see how things perform.   

 

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Yes, I understand that the printer only works on the 2.4ghz network, which is probably what it was still connected to after changing routers, since that SSID did not get renamed to anything different- I kept it the same.  So naturally, the problem now is getting it reconnected to the 2.4ghz side, which we tried to do, since during the setup process, it actually shows two SSIDs, but of the exact same name- no way to distinguish which one is 2.4 or 5.  And we attempted to set it up using each one, to no avail.  And therein lies the problem, getting it connected to the 2.4 side.  Something I obviously have to figure out.

 

And to your point that it is not the printer?  The printer still sucks.  Never did I have such problems with HP printers, at least as far as setup goes; the display screen had much more info on it and was much more intuitive than this piece of junk and there was at least a process you could follow just using the display screen on the printer, as well as the fact that HP tech support was WAY more helpful and less snotty.  This will definitely be my one and only Canon purchase of any kind.  And when I can, I will be buying another HP and probably have a little "Office Space" recreation with this thing...

 

Oh, and thank you for your input, it is appreciated...

Announcements