cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MG5420 WiFi connection problem

Hal2k
Contributor

The WiFi (WLAN) set-up works good all day after it starts.   But overnight when the printer is inactive it looses it.  When trying to print first thing in the morning I have to re-configure it using the "Standard Setup" method which involves typing in my WiFi password (a long and cumbersome process).  This machine is new (only 3 days old) and maybe this problem will eventually go away, but it hasn't for the last two mornings.   Anybody have this problem?  If so, how to fix?  Thanks.   

1 ACCEPTED SOLUTION

Hi Hal2k,

 

Yea, unfortunately you can't attach a word document or a text file, just a picture or video, but the 54% you are getting can definately account for the issues you are having.  Optimally you want that number to be around 70 to 80% if not better.  If at all possible I'd recommend moving the printer closer to where the router is, but if that's not possible you can try two things, one would be to access your router settings and try changing the wireless channel that your router transmits on.  If you are in an apartment complex or if you are in a neighborhood with other people who have strong enough wireless routers their signals can be overlapping yours causing signal loss and switching to a less crowded channel will help that.  If moving the printer or the router so that they are closer to eachother is not an option, your other option would be to purchase a wirelses extender that will strengthen the connection between your printer and router.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post

55 REPLIES 55

thevinci
Apprentice

I have the exact same problem with both my printers, MG5420 and MX432. My Mac would not be able to print documents properly for weeks with faded colors but worked on my Windows machine.

 

Now, all computers cannot connect to the printer. The printer is sitting right next to the router.

 

What the heck is this? Your latest drivers broken everything? Don't make me go after a class action lawsuit. All computers cannot connect to both your printers.

tgoh
Apprentice

I had the same proble. I upgraded my router to an N signal from a G signal. The stronger wireless signal is needed for the newer devices.

Ustlach
Apprentice

I had almost given up on this printer because of the wireless printing problem.  I was having the same problem most others have described, but decided to start over again and do a thorough search of the issue.  I eventually came across a Canon video and I watched it.  Unfortunately I cannot provide the link.  The second step, in the video, was to go through a setup procedure, and I believe it said there was supposed to be a DVD/CD that came with the printer and that it would take me through the setup procedure.  I did not get a setup DVD with my printer, so I went to the Canon website and looked for the setup procedure.  I downloaded it and it installed drivers, etc. that I am pretty sure I did not do when I first got the printer, did the setup on the printer, entering the modem password, etc.  I assumed the drivers were available to the device via Windows 7, which was apparently a faulty assumption.  So, the downloaded setup procedure did its thing, including downloading drivers, etc.  I had to go through the setup on the printer again, entering the modem password, etc.  And now the printer works wirelessly and keeps whatever it needs to do it, day in day out, and has not failed since I did this, over a week ago.  I turn the printer off when I am not using it.  When I turn it on to use it again, it continues to print wirelessly.

 

Apparently I was missing critical drivers that I only ever succeeded in getting by using that Canon setup procedure that I downloaded from the Canon website.

 

This has turned my attitude about Canon and this printer around 180 degrees.  I even went out and bought $80 worth of new ink cartidges, as the originals that came with the printer are almost empty.  (I used the printer for almost a year using a cable.  I don't print a lot.)

Some of the people who have posted messages in this thread have a problem totally unrelated to the problem described by the OP of this thread.  The OP successfully completed the wireless printer installation and the printer works except after inactivity.  These other people failed to complete the wireless installation.  They should have posted about their problem in a separate thread; hijacking this thread was inappropriate.  Also, there's already a lot of info available online to help them learn how to do the wireless installation.

 

So, please, no more messages here about not being able to do a wireless installation.  Only post messages here about printers that won't "wake up" to print (or scan) wirelessly after inactivity.  Thanks in advance.

richk
Apprentice

HI. I just got a new wireless modem from Xfiinity and subbed it out for my old modem and router combination. The printer was working fine before I made the switch. I can't seem to configure the printer to pick up the new modem even though I've found the network and added the password (many times). I keep getting a timeout message on the printer. I printed out the network configuration page if that helps. Says I have 0% signal strength. I'm not sure what else to do. Any help would be greatly appreciated. 

thanks.

Patrick
Product Expert
Product Expert

Hi richk,

 

How far from your router is your PIXMA MG5420?  The signal strength should be as close to 100% as possible.  For testing purposes, please move the router 3 - 4 feet from your PIXMA MG5420.  Is the signal strength still 0% ?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I would suggest going to the Canon website and find the section that has to do with drivers, for your printer, then use the link provided there for setting up your printer.  I recently went through a scenario similar to the one you described and that this was the solution that got me going again.

Joeknc22
Apprentice

I have fixed my problem, even to point of not using printer for a week and it was online when I got back home.  I connect to my printer thru a TP-Link range extender (TL-WA901ND) set to access point mode.  I changed my access point and my printer to static addressing rather then DHCP.  Found that the router for sure was chaning addresses occasionally.  Next in the access point settings under system tools I turned on "Ping Watchdog", this sends a ping to the printer tcp/ip address every 300 seconds. 

 

I added the access point to my network to extend the range not to fix the dropping problem.  The access point is relatively inexpensive in the $75 range thru amazon.

 

 

 

Joeknc22's solution is clever and I expect it will work well since access points (and routers) are typically left on all the time.  But I suspect it doesn't allow the printer to enter its low power consumption idle mode.

 

I recommend customers first try my solution: type the printer's IP address into the computer's web browser so the printer's Settings webpage can be accessed, then type a value into the "Location" field on that webpage and click the "Save Settings" button.  It's free and easy to try, and doesn't require any equipment be left on all the time.  I did it many weeks ago and the problem immediately went away and never recurred.

 

By the way, the TP-Link TL-WA901ND access point that Joeknc22 mentioned is selling for $38 at Amazon.  Some cheaper TP-Link access points also have the ping watchdog feature.

 

I read about a free website (PingAlive.com, located in Britain) that will periodically ping any IP address you want, but I'm unsure whether it can ping a printer that's behind a router that's using NAT translation (sharing an IP address) because PingAlive is intended to keep websites alive.

 

Customers who leave their computer on all the time could simply run their computer's ping utility, with the appropriate command-line options (the printer's IP address, the desired time between pings, and the switch to make it repeat forever).

Printer still drops into energy saver mode

Avatar
click here to view the press release
Announcements