Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma G7020 AirPrint Stopped working after iOS 17 update


Since Apple updated iOS to 17.1 and 17.2 and now 17.2.1 my Pixma G7000 has stopped showing up as an Airprinter- everything else works just fine, I tried solving this problem via chat but we couldn’t get it to work.  My phone sees the printer when we used a browser to the IP Address.

I have read that Apple changed or plugged a security leak in the Bonjour program and some printer firmware hasn’t caught up with that change.  I think that is what is happening for me. I tried seeing if there was a firmware update but the printer says that it has the most up to date firmware.
I would really appreciate a response on this, when will new firmware be available?  I am sure I am not the only one, others have had the same problem, I see posts on the apple community support groups for Canon printers.



I am facing the same problem with my G7020. Every time I go to AirPrint from Google Chrome on my iPhone, it kicks my printer off of the network from my phone. However, my printer is still connected to my Wi-Fi within my home and can print from any computer/laptop. 

The temporary solution I have found is to hit the top right hand arrow icon when you try to AirPrint and choose the save to "documents" option. Then go into the Canon Print App and choose documents and print from within the app. 

I had to delete my printer from the Canon Print App and re-add it to get it to come back online. 


I have this problem as well from any IOS devices with IOS >17 and with a Canon LBP622C. I have updated the printer firmware, tried to enable and disable IPv6 on my network, tried a wired connection but nothing helps. Airprint works great from my MacBook with Sonoma 14.5. I am also able to print from the Canon App on the IOS devices, but it's really annoying to have to go through that for every single print I need. Can Canon please address this? I saw on other forums that people have been able to fix this problem with firmware updates, but that did not seem to help with my printer.