Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma 5720 not finding router


I got this new printer and am having problems getting the wireless set up.  I can print from my phone and ipad.  I can print from my laptop running Win7 if plugged in.  I have installed the cd rom software and and I believe it went online to get the latest drivers.  For some reason, I just can't get the wi fi figured out.  I checked the LAN settings and it shows my SSID and says active sometimes and inactive other times.  I've gone through the wireless LAN setup and entered my wifi password multiple times and I get the red error message screen.  I've gone through some help tutorials and nothing seems to work.  I've tried the WPS method with also doesn't find the router.  I've tried cableless set up and cabled, selecting my SSID and entering the 14 digit passowrd and get the red error screen.  I'm at a loss.  I'm pretty tech savvy and this has me totally befuddled.  What am I missing here?  Also have the same issues on my wife's Win10 machine.


Product Expert
Product Expert



Troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance with this matter.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.