cancel
Showing results for 
Search instead for 
Did you mean: 

PIXMA MX892 - Not staying connected to LAN

jpilkenroth
Apprentice

I am beyond frustrated right now.  Just spent a LOT of money on a brand new Canon PIXMA MX892 last night....Set up was fairly simple, pretty easy to follow instructions.  In less than 45 minutes it was up & ready to go.  I printed out 20-30 pages of information for my upcoming vacation....Woke up this morning to do some work and my internet was down in the morning.  By the time the internet was back-up, I had to re-set my modem & router a few times & re-start my PC, and was finally able to synch the printer with the LAN to print again....however - after that it has been down all afternoon.  I have restarted the modem & router & my PC several times.  I have even unplugged & re-plugged the printer, and I've gone through the LAN set-up numerous times...NO LUCK.  I printed from my iPad moments ago with NO problems whatsoever.  It's like it's not picking up the LAN connection.  I ran the diagnostic report and the SSID name is correct.  I am about to pull out all of my hair.  I am going out for the evening, but have lots of work to do tomorrow and really need this printer to work.  For the money I spent, I really did not expect this level of frustration and technical issues.  I am not a PC expert, but not a novice either.  I have not tried connecting a USB cable, because I do not have one.  I will buy one if I have to, but that defeats the purpose of the WIRELESS printer that I spent extra money to purchase.  Ugh.

16 REPLIES 16

jpilkenroth
Apprentice

"Printer is not responding" is the error message.....

jpilkenroth
Apprentice

I went through the set-up process again with the installation CD.  Printed successfully ONCE, and now I'm back to square one.  "No response". 

jpilkenroth
Apprentice

So...I was on my corporate VPN...and by chance I disconnected to see if that would help and lo & behold I was able to print successfully.  So can I not be connected to VPN when I need to print?

Hi jpilkenroth,

 

The MX892 will not be able to print wirelessly while ou are connected to your companies VPN.  The reason for this is because when you are  on your companies VPN, you are effectively no longer on your home network as far as the printer is concerned.  If the pritner can't see the computer on the network, it won't be able to send or receive print jobs.  I've seen some customers be able to have the messages remain in the print que, that way they start printing when you disconnect from the VPN, but this would be the only workaround we can suggest.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

That's fine but I don't have a VPN (whatever that is).
All I have is my Dell laptop, my Dell desktop and an IPad and Galaxy Android cellphone.
Everything worked fine on the Epson but I thought the ink was too expensive so decided to switch to the Canon MX922.

I am having the exact same problem and I'm so frustrated I'm ready to take the printer back to Costco. Even after I ordered over $300 worth of ink!
I've found I have to resort to pushing the button on the back of the router and then on the printer to reconnect the printer to the access point - EVERY SINGLE TIME I need to print. This is worse than not having wireless!
I'll never ever recommend a Canon again. Air print or not!
My husband has a mac and had no problem

Hi, DeeDi!

So that the Community can help you better, we will need to know the version of Windows your computers are running.

Thanks and have a great day!

Windows 7 Home Premium

My Canon all in one plus air printer is the PIXMA MX 922 but the software the came with the unit is MX 920
Would that make any difference?

Although if the same problem exists with the MX 892 ....... then this is an ongoing problem?

 

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x