Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MG3222 will print but not scan ("Failed to open a connection to the device (-21345)")


I just got a new laptop, a MacBook Air 2020 running OS 13, and I am having the same problem as other Mac users with other printer models. The printing works, but the scanner says "Failed to open a connection to the device (-21345)." I logged into the IP address and disabled ipv6, per one person's recommendation, and turned off and back on the printer, but it still doesn't work. I also tried downloading the latest IJ Network Tool, but that doesn't help either. I am doing this while connected via USB.

It does print (wired, USB) fine.






Thanks for letting us know what Canon product you've got. The PIXMA MG3222 is an older model which we have retired. While that means that Canon USA no longer offers direct support for it, your friends here in the Canon Community are welcome to offer suggestions!

You can also speak with a Canon Upgrade Program specialist to help you score a modern replacement that would meet your current needs at a discount. You can reach them weekdays and Saturdays at 1-866-443-8002.

Hope this helps!

It's really not very old, and it's unethical to promote throw-away culture by encouraging folks to trash tech just because it's not brand new. A printer should easily last 20 years.