Showing results for 
Show  only  | Search instead for 
Did you mean: 

Not finding airprint printers on iphone for mf644cdw


Hi there, really struggling to figure this out over the last few weeks.


I can sometimes find the airprint printer but only after reseting my printer or reconnecting the wifi and then I can't discover it any more again after a little while (this is all while it says connected to wifi on the printer)



- updated to newest firmware.

- currently on a static ip address

- wireless lan on 2.4 Ghz band

- Imageclass mf644cdw

- not connected by usb to a computer (would this make a difference?)


IPhone 7

- newest software update

- on same wifi band

- this is happening on my ipad and other family members iphones as well. Other times they can discover it but I can't, even though we're the same distance away
- the crazy part is that i can log in to Remote UI through the IP address but can't discover it on airprint for some reason.



- newest software drivers

- also sometimes can't discover the printer

Windows 10 PC

- no problems over wireless




The issue is being caused by your router.  Assign the printer a static IP on your network.  This will ensure any device (wired or wirelesss) that is connected to your network will always be able to find the printer at the same "destination" IP Address since it will never change. 


This recommendation is a "set it up once" and not have to mess with it again suggestion.  Relying on your router unless told what IP to give a device will require constant "fiddling" and is not best practice for stationary devices.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Hey there, so my router currently has the printer set to a static IP, however, I'm struggling still to find it with my iphone on airport

If the printer indeed has a static IP set by you, I'm suprised you are not able to connect with an iPhone.


See this, might help:

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Hi magehunter45.


Since everything else seems to be in order, and you can access the Remote UI, try updating the printer's firmware.


Updates to Airprint's protocols come bundled in those firmware updates, so it may give the printer what it needs to be recognized once more by the iphone.


If this answered your question, please click the Accept as Solution button, so others might find the answer.

I know this thread is old but I wanted to jump in and say I'm having the same problem.


I have an MF644CDw.  Static IP address set.  Latest firmare.  Tried on both wireless as well as wired lan.


I have no problems with Windows 10 machines on the network, but none of the iPhone/iPads/and some Macs can access the printer via AirPrint.  If I restart the printer, it might work for a bit, but eventually within few hours, none of the iOS/Mac OS device can find the printer anymore.


Looking around the forums, lot of people are having this problem without a resolution.  I even see people returning their printers because of this presistent problem.  I tried all other suggestions I see on this forum as well including turn off IPv6, etc.


Any additional insights that can help us debug this?  I'm pretty close to calling it quits on this printer as well...


Thank you,



Chiming in on this as well.  I have an MF414DW and AirPrint started acting goofy.  Reset the whole unit, enable/disable/enabled AIrprint, pulled the power...all that stuff.  Just will not show up on any of our iOS devices.  This needs to be fixed.  I have the most up to date firmware available so nothing else can be done on the printer as far as updates go.  Help Canon!

Not sure if this helps anyone but making these changes on my router fixed my Airprint issue immediately.  

@theargonaut33 wrote:

Not sure if this helps anyone but making these changes on my router fixed my Airprint issue immediately.  

I think if the issue is that connection is dropping while you are priting, I can see some of the suggestsions on that site helping.  Although, I don't recommend ripping out all the advanced wireless features of AC88U as that website suggests.   Forcing control channel and such can have an adverse effect on your network - because some of that depends on how crowded your wifi space is.  Also, the article seems to suggest only thing that matters is Airtime Fairness, and that setting should be disabled by default on any of the newer firmwares for AC88u.


Issue I'm having (along with bunch of others that I can see when I search online) is discovery.  When I restart the printer, the iOS device sees the printer and it works fine.  But after few hours, maybe it's somet type of sleep setting or whatever, the printer can't be found anymore....and I hve to turn the printer off then on again....


Right I completely agree with you. I should have mentioned that I am all 5Ghz for the most part. I have a couple devices that are 2.4Ghz only devices and I only use 2.4Ghz for those and those are devices I'm not concerned about the changes made as they are light duty type devices.

Correct on Airtime Fairness, I should have mentioned Airtime fairness was disabled by default and I did not change this. From what I could tell the important things were the other settings.

I have had that sleep problem before as well. I've done some digging on these MF series printers and at least for my MF414DW there is no way to completely disable all the sleep features unfortunately. I don't understand why that isn't first an option and secondly why it is not addressed in a firmware update. It is clearly a problem.

Thanks for the reply.


EDIT: Just for clarity I have an Asus AX88u actually but the same settings should exist in most modern routers that allow a deeper level of options for settings.

click here to view the press release