Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX922 goes to sleep and loses WiFi connection


I have a new MX922 that replaced a dead MX870. The old MX870 worked fine until it died but this new MX922 doesn't work correctly on my WiFi network. And the only thing that's changed is the printer (all the other PCs and printers and the Wifi router are the same as before and still work just fine). The new MX922 goes to sleep and can't be woken up from any PC on my network (to print or scan). The old MX870 NEVER had a problem on this WiFI network and NEVER had a problem with sleep mode. I also still have two MX890s that still work just fine. When the MX922 stops responding to pings, the blue WiFi logo on the front is on, and the Network Configuration Page always says "Connection Active" (but it's not).  Any suggestions that it's my router or my PC driver's fault is nonsense. It's clearly a MX922 WiFi bug which Canon needs to fix ASAP.


Over the past few weeks I've discovered that if the printer goes to sleep for an extended period it frequently "loses" it's WiFi connection and nothing I do from my PC will let me print to or scan from it. Basically it stops responding to pings (which tells me that its WiFi network connection is the issue). I usually discover the printer is offline line first thing Monday AM (after the office has been closed all weekend).


When the MX922 goes into a coma the only way I've found to wake it up is to either power-cycle it, or do go into the Device Settings menu and print out the current Network Configuration Page (it sometimes starts printing/scanning again when I exit out of the menus). AND sometimes after waking it up via the menu trick it operates very very slowly (like the Wifi connection is poor or congested) and I end up having to power cycle it to fix it. I shouldn't ever have to power cycle the printer just to wake it up (especially since it probably uses up some ink to recharge the print head each time it powers on).


Since I got it about 6 weeks ago, this printer has gone into a coma about once a week. Recently I tried disabling the Wireless DRX option and that seems to have made it worse. Since I disabled that option, It's gone into a coma 3 times in the past two days.






First thing I did when I bought this printer is assigned a static IP to it.  I always have to turn the printer off and then on again after I send a job to it if it's been idle more that a couple of days.  I'm looking forward to dumping this sorry printer in the near future.  

View solution in original post

110 REPLIES 110

I called Canon's Customer Support 800 number. He guided me thru a diagnostic routine, recommended removing the printer driver and downloading/installing a new one from email he sent me (also available from Canon website. A week of frustration ended. Hallelujah. Give it a try.

There must be more than one problem with the MX922 because I don't see how installing a new windows driver could solve my issue (especially since I've already got the latest one installed). When my printer goes to sleep it also fails to handle jobs queued from the Google Cloud Print service (which doesn't involve anything other than my WiFi internet router). The Google Cloud Print staus says the MX922 is offline (even though the printer is awake) and the only way to get the MX922 back online is to either power-cycle the printer or re-enable Cloud Print from the front panel (power cycling just the WiFi router doesn't reliably start the queued up print jobs).

Yes, there may be more than one problem. Also, my printer is actually an MX892, but there are just as many posts about connection problems with that model. Still, give it a try. At best it works. At worst it adds another few minutes to the ones you've already lost to this problem. Good luck.

I have the same problem with my Macs and tried the Airport Utility fix, but it didn't work for me either.


'No configured Airport base stations......"

There was a button for Internet which I clicked. Just connection information.


I finally gave up and solved the problem by connecting the printer to my router with an ethernet cable.  Saves a LOT of time and frustration.

VTBlue, I was excited to see your post.  I too have a mac and I am having the same issue.  I went into airport utility to adjust my setting.... and unfortunately, they already match your settings.  This is driving me crazy.

SMUWiLLD, sorry to hear. Seems odd. Have you tried doing a complete shut-down (not a re-start), re-start, and then gone back in and tried clicking to undo the Airport settings, shutting down again, re-starting and then clicking and re-doing the settings? 

Give that a shot. 

Good luck.

HERE is the fix!!!!  Go to settings then LAN settings then other settings then " wireless LAN drx" and disable it.


Your printer will no longer disconnect! 

This is a power saving feature that is malfunctioning.


Merry Christmas



@harrybuckman wrote:

HERE is the fix!!!!  Go to settings then LAN settings then other settings then " wireless LAN drx" and disable it.


Your printer will no longer disconnect! 

This is a power saving feature that is malfunctioning.


Merry Christmas




DUDE! This worked! The problem was resolved instantly!

1) I followed your instructions
2) Powered OFF
3) Powered back on
4) Went to System Prefs on my Mac
5) Selected Printers
6) Clicked + to add a printer (I had previously removed the printer to clear my Mac printer settings)
7) Selected the DEFAULT setting up top -- and the MX922 showed up instantly!
😎 Clicked on Options&Supplies
9) Verified the ink -- which worked, and printed a test page!


My Canon MX922 menu does not look like that.

I hit WLAN setup then looked for 'other settings' and only saw 'Other setup options' which goes to 3 options: Standard, WPS, other setup.

Hit other set up goes to advanced setup

Hit that which shows router info only. No place to disable 


Am I looking in the wrong place?

click here to view the gallery