cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX922 WiFi password change issue

chrisgordey
Apprentice

Hi, I've had an issue for some time where I can't change the password saved in the printer for my network. I've been using it wired due to this issue. When I try to connect to wireless lan it says password incorrect. I have tried the Reset LAN settings option but it doesn't remove the saved networks and I must change my router ssid to make it work. Very bummed out by the plethora of issues I have with every printer I buy. If only it would ask for the friggin password.

 

Thanks for any insight. 

10 REPLIES 10

Patrick
Product Expert
Product Expert

Hi chrisgordey,

 

To connect your PIXMA MX922 to your wireless network, please follow these steps:

 

 1.  Turn your PIXMA MX922 on.

 

 2.  Press the MENU button on your PIXMA MX922.

 

 3.  Use the arrow buttons to select WLAN Setup and press OK.

 

 4.  Press the STOP button (to select Other setup options).

 

 5.  Select Standard setup and press OK.

 

 6.  Select your wireless network name from the list that appears and press OK.

 

 7.  Press OK to access the on screen keyboard and enter in your wireless network password.  Please note that this password is case sensitive and if it is entered incorrectly, your PIXMA MX922 will not connect to your network.  To switch between upper case letters, lower case letters and special characters, please use the middle function button below the LCD of your PIXMA MX922.

 

 8.  Press the left function button under the word "Done" once the password is entered.

 

 9.  Press the left function button under the word "End Setup".

 

10.  Press OK once your PIXMA MX922 is connected to your wireless network.

 

Your PIXMA MX922 will now be connected to your wireless network.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks Patrick! I spent two hours trying to connect my printer tonight after Spectrum did their maintenance last night & was just about to give up! Your answer is easy to follow! Thanks for your taking the time to help!!

I changed my WiFi password (same network name, updated password) and now the printer will not give me an option to enter the password. It recognizes my network and we click our network to connect and it does NOT Prompt us for the Wi-Fi Password so we cannot udpate it.  It's only recognizing the OLD Password.  How do we UPDATE the network with our NEW Password, so we can connect our printer.  I am not getting the option to CHANGE/Update the password! 😞  We have a CANON Pixma MX7520. Please advise! I am pulling my hair out I am so frustrated! Thank you!!!!

My printer skips step 7. I can go back to my old wifi and it goes to step 7. On my new wifi it does not give you the option to change the password -- no keyboard appears in the setup sequence. I get an error screen telling me it failed to connect. 
There is no WPS button on the wifi.

I have done all these steps.  I have also done a "reset of my LAN"  and then went to reset the wireless, it saw my access point (SSID) but when i clicked on it, it never prompted me to enter the passphrase.  whatever password it thought it had (in my case, there was no WPS button on my router) and i have to apparently, enter my pwd in manually, but no matter which path i take the printer seems to think it knows or not, the passphrase.  I read one discussion that i needed to "disable" wifi.  I assumed that is what the reset did.  However, i am never prompted for a passphrase, but rather a failed attempt at connecting

chrisgordey
Apprentice
Thanks but you clearly didnt read the post. I changed my WiFi password and now the printer will not give me an option to enter the password. It will only tell me it is incorrect. I have tried the reset lan option but it still has the network ssid saved with the old password. I want to change the password, not add a network.

I'm having the same issue, though my password hasn't changed. Once I select the access point and hit "ok", I get an error message and #2 on the list is to make sure the password is correct. All of the Canon videos say to enter the password. Hard to do that when you don't get the screen to do so. If you figure it out on your own or elsewhere, please update your post so I can do the same thing.

Hi melesca,

 

It is recommended that you contact one of Canon's Technical Support Representatives. To contact a Technical Support Representative, please use the link below:

http://Canon.us/ContactLI

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Did you get this issue resolved?  Do you remember what you had to do?  I'm having the same problem.  

Avatar
click here to view the gallery
Announcements