Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX892 not online every morning


I have a new MX892 installed on my network (wirelessly) and I have observed that after the printer has gone idle for some period of time and seems to go into its sleep mode, that it goes offline and cannot be accessed by other machines on the network.  I know that my wireless router (Cisco e1200) is working just fine since I have PCs, Macs, Unix machines, ipads, iphones and Lexmark laser printers all connected to it, everything is on backup UPS protectors, and nothing else looses its connection.  However every morning after being idle for some period of hours, the MX890 is offline again.  Each morning we have to go and turn it off and turn it on again.


I am guessing that the low power eco mode causes the MX890 to not renew its DHCP lease and the only way to renew it is to turn it off.  This seems consistent with other complaints I see on this forum.


How do I change the configuration of the MX89 so that it doesn't go to sleep or  eco mode or enable the printer to at least renews its DHCP lease whenit expires?



Hi. I just joined the forum as you for similar problem, but what you are saying was just the bigining !
I have Canon MP495 It was like you are saying for an almost a year and now the wireless priting does not work at all! The port 515 is open, the WEB Interface work just perfectly, but the printer its not recognizible from the OS (windows 7) I added then manualy but it start looping on "Collecting printer status.". So I will fallow this thread with you my friend.

Regardless your post - You can put a static IP to the printer by the WEB interface (if it has such) or even better, to reserv the printer IP from the router.


Hi Djl!


There are a few things that can cause the printer to go offline and it is usually related to the Windows computer. 

The Windows Firewall or third party firewalls could cause this to occur.  Please try disabling third party firewalls to see if this resolves the issue.  To temporarily disable the Windows Firewall, please follow these steps:


 1.  Click on Start and then Control Panel.


 2.  Click on Security Center and then Windows Firewall.


 3.  Select OFF and then click OK.


Once set, please attempt to print.  If the issue persists, please try this:


 1.  Turn the PIXMA MX892 on.


 2.  Press the Setup button.


 3.  Use the left or right button to select Device Settings and press OK.


 4.  Use the up or down button to select LAN settings and press OK.


 5.  Use the up or down button to select Confirm LAN settings and press OK.


 6.  Use the up or down button to select WLAN setting List and press OK.


The IP address will be in this list, please copy the address down on a piece of paper.


On the computer, please follow these steps:


 1.  Click on Start and then Control Panel.


 2.  Click on Printers.


 3.  Right click the PIXMA MX892 and left click on Properties or Printer Properties.


 4.  Click on the Ports tab.


 5.  Click the Add Port button.


 6.  Choose Standard TCP/IP Port.


 7.  Click New Port.


 8.  In the wizard, click Next and then type the IP address of your printer in the box.


 9.  Click Next.


10.  Click Finish.


11.  The checkmark should be next to the port that we just created.  If not, please checkmark it.


12.  Click Apply and OK.


The issue should be resolved for you.

I had similar problems with my MX892.  It's set up all wirelessly.  It worked flawlessly since the first day.  I suffered a motherboard failure on my primary PC, and in the act of replacing the motherboard, I cracked my drive array and had to restore from backup and reload and reconfigure a lot of many key programs.


After getting everything set back up properly (or so I thought) I noticed that when the printer would go to sleep/power conserve mode, it would lose connection to the router.  It was easy to reconnect, just power cycle the printer, but it was annoying.  I looked for the solution here and other sources and finally found the answer after a few weeks of frustration.  


In a nutshell, the way I had re-installed my firewall was not allowing the printer to stay connected to the port.


During my initial setup of Windows I ran through the setup process quickly, and with previous settings that I had already knew.  However, when I re-installed my McAfee A/V and firewall, I selected the default settings, instead of manually selecting them, and it set my network to "work" and this conflicted with my pc settings.  (I can't remember the exact specifics).  I wasn't sure if that was it or not.  I fixed this a few days ago, and it's been fine ever since.  


I also took the time to review my firewall settings and rules to eliminate items that I no longer used or needed and cleaned that up a great deal.


I also set the printer to a dedicated IP address on my router (Cisco Linksys E3000) so I eliminated that as a source of the problem.

One more item to note.  I also went into the printers web interface and updated it there to always use the same IP address.


To do that, find out the IP address of the printer (steps in a message a few threads above this one), and then enter that IP address in your web browswer.


Click on the "Advanced" tab, and then from there, select the "Network Settings" tab.


Within that page, you have the option to "Get IP address automatically" or "Use the following IP adress"


Enter the printer IP address in the "Use the following IP adress" field.


Make sure though, that your router has that IP address reserved for the printer such that it does not renew to a different one.


I haven't had any connection problems since that time.

this instruction works great up to the point where I add the port and enter the IP Address and then Windows never comes back with finding the printer.  So when I click Next at Step 9 i get a dialogue that says Device not found on the network.  I am able to print wirelessly from Word to this Canon printer however.  I hate this printer and its wireless problems.  My Brother printer was up and running without issues from day one.  This is really frustrating Canon

click here to view the gallery