Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX892 constantly goes offline from Google Cloud Print


Hi there,


I have two separate MX892 printers in two different locations.  Both are setup to connect wirelessly and both are setup with a google account for Google Cloud Print.   When either is first powered on, everything works great - I can print wirelessly from any computer on the network, and I can also print via Google Cloud Print.  However, sometime within 24 hours, they will both go "offline" for Google Cloud Print, even though I continue to have no issues printing from any computer from their respective local (wireless) networks.  Everything contiunes to work as expected except cloud print.  


Why does the printer keep going offline for Google Cloud Print?  If I power cycle either printer (via the power button on the printer), once it's back up and on, it's back online for Cloud Print for a short amount of tome. 


Any suggestions?   


Did you solve this problem. I'm having the same issue with my MX922.

Nope, I also tried setting a static IP on the printer to no avail.  I contacted canon support directly and was told that I would indeed have to restart the printer everytime it goes off line.  Not a solution if you ask me.  

I have the same problem with MX 922. Also the remote print by email works sometimes and sometimes not and tech support has no reason for it.  The ONLY reason I purchased this printer is for the remote print feature (to be able to leave note/maps/instructions) for caregivers for my elderly mother.

yep, I hear you - the reason I bought this printer for myself and my parents is so that I can remotely print to their printer whenever they need something online and have problems finding it themselves to print.  However, since this always goes off line from google cloud print every 24 hours and therefore I have to have them reset the printer, this is the exact oppesite of what I was looking for.


Note, however, if the printer is showing offline on google cloud print, and from the printer menu settings (on the printer itself) I go to the settings -> cloud print -> check for print jobs, it will find any new print jobs and print them right then and there.  

Thanks but again that is not remote printing.  I will also try assigning a static IP address as that's worked for me with other network devices in the past; but I'm not optimistic since it didn't work for you.  If I can't resolve this I may return it and at a minmum will post a negative review on Amazon.  Again, the remote printing is the ONLY reason I bought it, so not having that feature work is not really acceptable.



Additional troubleshooting will have to be done to narrow down the cause of your issue.  Please contact our support group using the link below for additional assistance with this matter.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi Michael,


Thanks for the response, but I've already reached out to your support group.  The solution was essentially to power cycle:



"The issue may also be related to server loads at Google.  In some cases, Cloud print communication may lag which causes timeouts.  Please wait a while or try printing again at a later time.

Unfortunately, if the issue persists we would have to advise that you power cycle the printer in order to refresh the connection with the device.  I apologize for this inconvenience."



To Michael -- sorry but my problem is much worse.  My printer now will not connect to the internet at all.  I contacted support via email and they gave up and told me to call phone support.  I contacted phone support and after a half an hour the "network expert" GAVE UP.  At this point nobody at Canon has an answer as to why it is not working and as this is the ONLY reason I purchased it I think I am going to have to return it.  I have been a loyal Canon customer for years and bought nothing but Canon cameras and printers and to say I am extremely disappointed in Canon's response to this would be a gross understatement.  I can't waste any more time calling or emailing your tech support since they have given up.  If somebody at Canon thinks they can fix this then they need to call or email me.



Just checking for any other potential fixes here?  I now have a MX922 and it, too, has the same issue (and I've since moved and now have a different ISP as well as a different router and modem, so that all but rules those items out for being the issue)

click here to view the gallery