Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX892 Keeps losing connection when needed.


I don't have a straight USB cord for this thing, and I'm ready to go all 'office space' on it.


It'll work for a good while, but whenever we actually need it. (it will fail!)


It'll say 'Printer not responding' in the canon box.  
The 'Windows 7' box - says ' Error-Printing'.  


The Canon IJ Network Tool says - 'Canon MX890 Series Printer' - Status: Not Found - Port Name: CNB##Masked###


However I can get it to work intermittedly by... 1) abruptly, Pulling the power cord from the printer ... 2) cancelling any failed print jobs... 3) then after putting the power back in, it will accept print jobs again through the wireless network.


But of course these steps are entirely too much for my wife.

I tried to plug it - wired to the lan.  But it says I need to temporary plug it into USB which I don't have.  I can get one.



Hi Lele,


Since it's working sporatically, i'm wondering if it is set up to use the correct port.  Ive seen some cases where when it uses a built in port for WSD it will print erratically, but when we switch it over to the dedicated Canon port everything works fine.  Let's try the following:


1.  Click Start.


2.  Click Control Panel.


3.  Click Hardware and Sound.


4.  Click Devices and Printers.


5.  Right click the PIXMA MX892 Printer and click Printer Properties.


6.  Click the Ports tab.


7.  Make sure that the checkmark is on the port that starts with CNBJNP, then click OK and try to print.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Drivers were correctly assigned to the printer.  , This didn't work either - still cannot print over wifi using my PC - it says printer offline.  Can still scan to the PC wirelessly and all other devices can still print wirelessly.


Other suggestions?







Product Expert
Product Expert

Hello Lele.


Additional troubleshooting will have to be done to narrow down the cause of your issue.  Please contact our support group using the link below for additional assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

One more item which I hope can lead to an answer.


I have used "Uninstall" to remove the Canon MX892 drivers and then used the CD to setup the MX892 drivers four times on my PC, and everything works - printing, scanning etc.  The next time I power up my PC, wireless scanning still works but printing does not.  


So I know it works but printing stops working after the next reboot.  Any thoughts?

Product Expert
Product Expert

Hello Lele.


At this point, we would have to recommend that you contact our support group.  Please use the below for additional assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have the same issue as Lele described.


I have MX892, linked to wireless router. I have iPad, iPhone, laptop with Windows XP, Windows 7 and Windows 8. XP is 32 bits, Win 7 and Win 8 are 64 bits. There is no problem for Apple products and Win XP to connecto to the printer. But the Win 7 and Win 8 could not find the printer after the PC is logout and re-login. It showed the printer is offline. 


I download the most recent driver from Canon USA website (Driver for Windows x64) and re-install the printer on Win 7 and Win 8. Still can not solve the problem. Any idea whether the problem is related to OS system? 


It works just fine for Win XP (32 bits) and Apple products. Everytime when I reboot the PC or iPad, they can find the printer. 






I have an MG6200 that got the same message "There are ports that cannot be used..." I switched to wired and reset printer to LAN, no luck.  I switched to wireless and set up that.  No luck.  I set back to wired, and went to DOS PROMPT and pinged the IP address from the wired lan.  Then the printer started printing happily away.  I think there's a problem with the proprietary IP communication that Canon is using.


On 2014-10-06 I posted the details of the solution that worked for me at a similar Canon forum:


It continues to work for me.  The wireless printer connection hasn't failed since then.


It's a permanent solution that you only need to do once. (It isn't a workaround that wakes the printer temporarily after its connection fails.)


The solution involves using your computer's web browser software to access the printer's built-in web server (by entering the printer's IPv4 address into the web browser's address field), going to the printer's Settings webpage, and entering a value in the Location property. (Which was blank by default.)


If you try it, please post (preferably in that other Canon forum) a few days afterward, to report whether it solved the problem.


Good luck!

Worked for me today 2014-01-13. Thanks so much for sharing!


My MX892 worked fine for a few months, but it now seems to "forget" its connection to our local network after every use.  This means that we have to manually key in the password to the network every time we print for it to work.  Otherwise, we get the "printer not connected" or "printer not reponding" messages.  


What's the deal?  Is there a fix for this?



click here to view the press release