cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator X and macOS Mojave

tobiaspandey
Apprentice

My father has a canon scanner Lide 110 that uses MP Navigator X.

That software does not longer work with macOS Mojave, it wont even start. That sucks.

Does anyone know of a good scanning software that works with Lide 110?

Preferably software that detects multiple photos and saves them individually as jpegs.

thanks.

1 ACCEPTED SOLUTION

robp
Apprentice

Here's something you can try..

 

Keep your MP Navigator 3.1 installed (for now)

 

Install the MP Navigator 4 from the link canon asia link above

 

go to Applications/Canon Utilities

 

Right click on MP Navigator 4 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the asia 4.0 version of the app supports

 

Right click on MP Navigator 3.1 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the us 3.1 version of the app supports

 

Copy the files from the 3.1 database folder to the 4.0 database folder

 

Now when you start MP Naviagor 4 it will launch correctly and find your scanner.

 

I have not analyzed the contents of these plist files so I'm not 100% sure if this will work, but the contents of the files in the 3.1 version look pretty similar to the ones provided in the 4.0 version.

View solution in original post

69 REPLIES 69

interesting Lisa, but I see the URL is for Canon Asia. I'm wondering is the Asian version has any compatibility issues with the USA versions of the Canon drivers and with the USA versions of Mojave. Which OS flavors are you using this version of Navigator with?

Not that Navigator is working at all now, so that could not get any worse, but I have visions of turning my whole system into a brick.....

Just to follow up on this. I've got a Canon Lide 110, upgraded to Mojave and this link has worked for me, unlike any of the other suggestions on the thread so far. Thanks for posting!

Thank you, it worked perfectly! First removed all old MP software and then installed the MP Navigator from the link. Works again as usually! Learned: Keep calm and read!

Best Blueberry!

jennykay85
Contributor

MP Navigator from the Canon Asia site won't work for my model (MG6220). Per the error window:

 

Screen Shot 2019-01-15 at 1.03.14 AM.png

Yeah, I got the same error message with a US version MG5320. I guess American Mac users have been abandoned by Canon .. perhaps unless we have the newest, newest printer/scanner. And I don't know if even those would be compatible. I hated my old HP AIO and used to like my Canon. I'll probably try Epson next. 

Although these Navigator hybrid solutions seem to work for folks with dedicated scanners, none of these work for my MG5320 AIO printer/scanner on an I-Mac with Mojave. There is a workaround that does work for me. Open system preferences/ printer scanners and select scanner.  You can operate the scanner from there and save various types of files. But you have no editing capability. It's a kludge and not what I paid for. As I said before, I feel totally abandoned by Canon on this. Canon scanning devices should be sold with a discolsure label, "Mac users not supported." It's ridiculous that Canon is relying on user blogs to support basic usage of their devices on a major operating system. Boo hiss Canon.

 

Download the Cannon IJ Network Tool from the Canon Knowledge Base (just google "Canon IJ Network Tool" and it will bring you the the right page to download it) and once downloaded, execute the IJ Tool program. It will find your canon printer on the network, and select your printer name, then click on "configure" to reset the printer's settings automatically. Once done, use the "Image Capture" as part of your MAC OS to scan your doc's.

robp
Apprentice

Here's something you can try..

 

Keep your MP Navigator 3.1 installed (for now)

 

Install the MP Navigator 4 from the link canon asia link above

 

go to Applications/Canon Utilities

 

Right click on MP Navigator 4 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the asia 4.0 version of the app supports

 

Right click on MP Navigator 3.1 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the us 3.1 version of the app supports

 

Copy the files from the 3.1 database folder to the 4.0 database folder

 

Now when you start MP Naviagor 4 it will launch correctly and find your scanner.

 

I have not analyzed the contents of these plist files so I'm not 100% sure if this will work, but the contents of the files in the 3.1 version look pretty similar to the ones provided in the 4.0 version.

This^^^^^^ worked perfectly!

 

I have a Canoscan 9000F.

 

Thanks a TON robp!

Yeeesss! It work. I have a Canonscan 9000F.

A lot of thanks robp!!!

Avatar
click here to view the press release
Announcements