cancel
Showing results for 
Search instead for 
Did you mean: 

MG7120 won’t print wirelessly all the time

essephenn
New Contributor

MG7120 printer sometimes displays an IP address and is recognized by devices to print. Then it “loses” its IP address and printer not found by device.  Rebooting router, printer, etc. occasionally works but then the problem is repeated usually when printer is idle for a while.  Using a Netgear AC 1200 R 6120 router with a wireless connection to printer. They are placed right next to each other physically. Any ideas? 

2 REPLIES 2

Patrick
Product Expert
Product Expert

Hi essephenn,

 

If the printer goes into sleep mode, the router may lose connection with the printer.  It is recommended that the printer is turned off after use.  If this is not an option, please disable sleep mode:

 

1. Press the Home button on your PIXMA MG7120, if available.

 

2.  Swipe the screen from left to right and tap ECO Settings.

 

3.  Tap Energy saving settings.

 

4.  Tap Auto Power Off and select "Never".

 

5.  Tap Auto Power On and select "On".

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks. I made those changes and like before it worked (printed) for a short while and then stopped.   I do turn the orinter off.  Not sure how consistent this is but it seems when it is turned on, the router assigns the IP to the printer but IOS devices just don’t recognize it.   Using the same wireless network and turning off/on the device makes no difference.   Using a Netgear router and wonder if the problem is the printer’s or the router’s?