Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG4120 print driver fails, scanner works!


I just purchased a new MG4120 for wireless printing. I tried to install on my Windows 8 desktop, first using the CD that came with the unit. I added it to my network using the WPS feature, and it was found and recognized fine. After installing the drivers and other software, the unit would scan wirelessly with no problems, but would not print. In the Windows 8 control panel, the printer is shown, but it says "driver unavailable."


I unistalled, and downloaded the current drivers for Windows 8 64-bit from the Canon website, and got the same result. No matter what combination of uninstall/reinstall methods I try, I always end up with a scanner that works but a printer that doesn't.


On my wife's Surface RT, I added the printer through the Add Device feature, the driver and app downloaded and she can now print wirelessly directly from her Surface. Another check that the wireless network is not the problem.


Any ideas on why the print driver is either not installing, is installing and not working, or is not compatible with my Windows 8 desktop?




Rising Star

Hi wrgilman,


When you attempt the installation using the drivers from our website on your Windows 8 desktop, do you run into any errors.  If so, what is the exact error that appears?


For immediate assistance with this issue, please feel free to Contact Us!

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi MarkII,


No errors whatsoever. The installation proceeds normally, and it even says that everything has installed correctly at the end. However, the driver is "unavailable" when you look at the properties of the printer.


I tried using the Metro UI of the Windows 8 PC, in order to install the printer the same way as it was installed on my wife's Surface RT. That installation begins to work, but it stops and displays "driver is unavailable."


I did some online searching, and this same problem has been encountered by others. No one seems to have found a way to fix it, though! Others, however, have had no problems on a 64-bit Windows 8 desktop. Very strange, something is not allowing the drivers to install - could it be interference with another printer (I have a Kodak AIO 5300 connected via USB) or something else?



08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5