Showing results for 
Show  only  | Search instead for 
Did you mean: 

Install Driver, new version number shown not updated (MacOs)


I have a LPB6230DW, updated the driver from 1.54 to 1.59 and it still shows being 1.54. I would like to make sure the newest driver is installed.

MacOs 12.3.1, M1 MacBook Pro. I tried to delete all instances of the printer driver in the system, and re-install, still not updated. Possible I missed something I guess.

Any ideas?


Product Expert
Product Expert

Hello Rdwintheiser,

In that situation, you can try resetting the printing system on your Mac and then trying to add the printer again to see if the new version of the driver appears. In printers and scanners, you can right click on a blank portion of the printers list and then select reset printing system. 

Once the system has been reset, you can click the + at the bottom of the printer list to open the add printer window and then add the printer back to see if it is now using the newest version of the driver.

If you continue to have issues, I would suggest contacting our support team at 1-800-652-2666. Our agents would be happy to assist with the getting the newest version of the driver installed.