Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageClass MF743CDW Connects to WIFI but not recognized to add printer


I have followed the instructions on installing this printer. I have got this printer on Thursday and still trying to get it added to my devices.  I have tried several devices and even though the printer shows its conneceted to my SSID when adding a printer it isnt listed.I have tried using the IP address and it tells me it cant recognize the device. I am beyond frustrated.  After spending this amount of money and taking this long to conneect. 

Jen Turnbaugh

Product Expert
Product Expert

Hello JenT78,


If the printer is connected to your network and has an IP address but the computer can't connect, it could be caused by the drivers that are installed, security software or network communication.


To see if the computer can get to the printer's address, you can try opening a web page on one of your devices and then typing the printer's IP address into your address bar and pressing enter.  If you are able to get to the printer's login page, you can try turning off any security software for the computer and you can try connecting again. If you are unable to get to the address, you can try unplugging your router from the power and waiting 5 seconds before plugging it back in. Once the network is back up, you can check if your devices can get to the IP address of the printer.


If you are still unable to get to the address of the printer, we would need some additional information to assist further. If you could reply to this message with the information below we can provide additional steps.


  1. What version of the Mac or Windows operating system are you using on your computer?
  2. What is the printer's IP address and Wireless Status? HOW TO CHECK

For a more immediate solution, you can create a Canon Account and contact our phone support team for assistance as well.


Good Afternoon,

I have contacted canon several times via phone and none of the methods seem to be helping.  I ordered the ImageClass MF743CDW on September 5, 2022.  I was able to imstall the printer and it worked properly up until last month.  In order for me to use the printer I have to reconnect it to the wifi.  Then it works.  However, if I go to print 30 minutes later I am unable to do so unless I reconnect to the wifi again.  It's a constant cycle.  I have uninstalled and reinstalled the printer, I tried changing the IP address, I also called my wifi service provider and they rebooted the router an it keeps happening.  At this point it's very frustrating.

Please help!

Hello JamaraYvette,

The issue points to a poor connection or the wrong driver being used on the computer. We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance.

  1. What version of the Mac or Windows operating system are you using on your computer?
  2. When you are unable to print, do you get an error on the computer or what happens?
  3. When you are unable to print, are you able to view the printer's ip address and view the remote UI?

MacOS Big Sur- Version 11.7.6

The printing log just shows my computer trying to connect to the printer and eventually it will say cannot find the printer.

Since I purchased a wifi extender, I have been able to connect to the remote UI. However, even with the extender, I'm still having issues.  I had to manually input the IP address to download the printer to my computer but then I am unable to print 2 sided.

When I connect to the remote ui it says Printer: an error occurred. 

Hi JamaraYvette,

Based on the information you provided, I agree with Hector's assessment.

The first thing you should establish is connectivity.  You said the printer worked for a period of time.  Has something changed or was the printer moved (proximity to the router)?  What prompted the purchase of the extender?

Tell us more about your network.  Is your equipment provided by your ISP, a mix or something you purchased on your own?  What's the brand and model(s) of the equipment?  How far is the printer from the router, router or extender, etc.  Proximity?

The information you are providing is contradicting.  First you say you have been able to connect to the printers Remote UI since purchasing the extender, then "when I connect to the remote ui it says Printer: an error occurred".  This doesn't sound like a successful connection.

Thus far it sounds like the printer is not maintaining a connection to your network.  Error when you try to view the printer's webserver in the browser, etc.  This could be a proximity issue or configuration issue with the network.  The better understanding we have of your environment the easier it will be for us to try and help.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

The printer and router are in the same place since purchasing the printer on September 5, 2022. I was promoted to get and extender because a rep recommended it when I called canon. Yes, before the printer started acting up I was able to access the remote ui when the printer started messing up I was not able to access it. When I purchased the extender I was then able to connect to the remote ui again. Yes, when I log into the remote ui when you look at the printer status it says an error occured

Enter for a chance to win