Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon TS9020 Not Connected Message


I'm having a frustrating issue with my Pixma TS9020 that we just purchased. It setup rather easily, and worked for awhile. Then we started getting "Printer Not Connected" messages when we tried to print documents. Confirmed all devices on the same network, and printer was on. Firmware and OS are all most recent (Mac OS High Sierra).


The only thing that fixes it is restarting my wireless network. It will then see the printer and print a few times. If we let it sit for awhile (not sure the exact time) and come back to print something later, we get the same Not Connected message, and again a wifi network restart fixes it.


This is very frustrating. I shouldn't have to daily restart my wifi network every day just to print. Any ideas? I'm an avid troubleshooter, so I'm hoping there are some things I can try.


Product Expert
Product Expert



Troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


If restarting your wireless network resolves the problem...  then setting a static IP on your printer, so that it always gets the same address will solve your problem.  


I'm probably starting to sound like a broken record and have posted 6 or more times recently regarding this behavior. 


User installs printer, connects to his/her wireless network.  Router or DHCP server gives the printer an IP address, printing is successful.  Printer goes to sleep (waiting for its next job)


The router or server doesn't hear from the printer and/or the DHCP lease time expires.  The router or server doesn't know the printer is still on the network "waiting" to be used.  It reclaims the IP address it assigned to the printer in anticipation of assigning it to a new device that joins the network.  Devices come and go.  The pool of IP addresses isn't unlimited.  The router or server does its job so it has IP addresses in reserve to hand out. 


Now you want to print again.  You send a job to the printer from your computer.  This is sent to the router, print to the device at IP address...  blah blah blah...  But the printer doesn't have that IP address anymore.  The IP has changed and the job fails because it has no known destination. 


How do you fix this...  give the printer a static IP afddress.  Your router or DHCP server will always give the printer the same IP.  It will never give that IP to another device, even if the printer sits for days, weeks or is turned off.  When it wakes up or is turned back on, the router says, "I know you"...  your IP is.... (static one you've assigned)


Now your computer can send a print job to the printer with an IP address of...  (the one that never changes) and any device or computer connecting to the network can always find the printer because it ALWAYS has the same IP.   


This takes all of the guess work out why devices cannot find your printer on the network.  It puts you in control by ensuring the destination.


You cannot rely on consumer grade networking equipment to identify devices connected to a network by their hostname, MAC address or last known IP.  I am not referring to the printer, but instead to the router. 

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi Rick, I just saw that you replied several months ago. Thanks for your thorough response. The reason I saw your reply is because I logged back in to check this post because I'm still having the issue. 


I had in fact already set the printer to a static IP. I think I did that immediately after I posted the original question. But that didn't seem to fix the issue. I set my router to a range starting at .100 and set my printer to .99. I then reinstalled printer drivers, etc and re-added the printer. Now a complicating factor is that I use all Mac computers, so maybe my issue is related to Mac OS, but I don't have this issue with other printers.


Perhaps I have to add the printer as an IP printer instead of the traditional way using Mac OS. I'll give that a shot and see if it helps.

click here to view the gallery