Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Pixma MG7150 wifi connection problems


We recently purchased a Canon Pixma MG7150 printer so that we could wirelessly connect to our windows 7 laptop, and all our apple devices. 


We were able to set up the printer following the instructions and it worked no problem.  However, everytime we now go to print something we are constantly getting a message saying airprinter not found when trying to print from ipad/iphones.  All the iphones/ipads have the latest ios software on them so that is not a probelm and the printer has the latest firmware too.

There is no problem with ink either.


I tried to print a photo from my ipad and in the canon pimxa app on ipad it shows the canon mg7100 series but when I go to print it says airprinter not found. 


The whole point of buying this printer was so that we could print via wi-fi but the only way to resolve this issue is to reset the hub everytime you want to print something which is extremely frustrating to the point that we now regretting buying the printer. 


If anyone can help or advice how to resolve this issue it would be much appreciated.





I have the same issue with my Cannon. I came here looking for an answer but from the looks of it users are on their own. All I have seen so far was reinstall drivers which is not the issue. I have to turn my printer off then on again and wait a little bit and it will see my printer again. Rebooting a hub seems like overkill.


It seems to me that the issue is a network one. Not sure if it's on the router or if Cannon needs to add software to refresh the network on it's side.

Hi Roxbury!

To ensure the most accurate information is provided, we will need to know the version of Windows or Mac in use.

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).

Thanks and have a great day!

Hi Roxbury


I contacted Canon support in UK, and they advised me to go in to the settings on the printer and disable the IP/V6 setting so that the printer only used the IP/v4 setting.  I did this and it seemed to work okay for a day or two.  It then did the same thing again it could not find the printer.  I contacted the forum again and they then advised me to go in and change the drx settings on the printer too which I did.


I also went into the printer and manually input my IP address into the settings instead of allowing automatic set up.


I also called BT and said that I had been having issues and they made some changes to a line with less interference as IP address kept constantly changing.


Since then I have been able to see the canon mg7150 printer from all my devices so it seems to have worked. 


I would recommend that you do the above to see if this resolves the problem. 


Touch wood this has worked for me so far.






I originally posted this, and thought that I had managed to fix the problem.  BUT the solution was very short lived.  I am becoming extremely frustrated by the whole issue.  The only way to connect wirelessly is to reboot my BT HH3 so that it can find the printer.


I disabled the settings so that IPV/4 was the only one used and also the wireless lan DRX setting was set to disabled too. 


I spoke to Canon who said that it could be the fault of BT so speak to them.  They are basically saying that the connection is fine and that it a canon problem.  I am going round in circles here without any solution to the problem about connecting to the printer. 


BT will not give me a static IP address unless I am a broadband business customer. 


Does anyone have any suggestions how I can resolve this.  I have tried resetting the printer and hh back to factory settings and starting over again.  It works for a short period then stops. 


If anyone can help I would be grateful as getting very very frustrated here.




Hi Swatt2015!

Welcome to The Canon Forums, and thank you for your inquiry!

We appreciate your participation, however we need to let you know that the Canon Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please click here and select your country or region for your support needs.

Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th