cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to google cloud print

thatch
Apprentice

We recently bought a MF8580cdw and installed it wireless, very easy.  Scanner works great.  We are mostly Mac but I want to use my Chrome book to print.  When I try to enable Google print in the remote UI and hit Register I get message "Failed to acquire information for registration".  I see in the enable area Install CA Certificate.  When I check CA certificates there appears to be 5 pre installed.  I have checked the e-manual and don't find this error listed.  Checked on line and didn't seem to get a good hit.  

 

Update 24 hrs later.  I Found that the SSL connection check box was not checked.  After checking this the printer registered fine and it is now printing from my Chrome Book.  I did not see any reference to make sure that SSL was enabled.  sSmple fix but hard to find.

30 REPLIES 30

jojogunne
Apprentice

I have the same issue, except checking off SSL is not working for me.  Anyone else????

JW0914
Apprentice

This may or may not help some, but should help others...

 
I was able to register cloud print successfully last week, then today it presented an error that it couldn't connect to the server.  After de-registering and then re-registering, I received the "failed to acquire information for registration" error.
 
After quite a few failures, I thought the outbound IP filters I set up may have been the issue, so I disabled it.  After a few more failures, I decided to power cycle the printer (switch off, wait until all lights shut off, switch on), and this allowed for the weblink to be generated in order to register the printer with cloud print.
 
It should also be mentioned SSL needs to be set and generated for the printer (Admin login - Network Settings - TCP/IP Settings - SSL Settings).  I assume this is so that all information sent to the printer while printing over the internet is encrypted with SSL.
 
 
Steps
1. De-register cloud print if previously registered.
2. Turn off, then back on, Cloud Print via the Remote UI (Login as Admin, navigate to Network Settings - Cloud Print Settings)
3. Navigate to Network Settings - TCP/IP Settings - SSL Settngs and register the SSL cert for the MF8280cw (if not already done)
4. Power Cycle Printer via the On/Off Switch
5. Log into Remote UI as Admin
6. Navigate to Network Settings - Cloud Print Settings and attempt registration again
 
If that fails, and you have IP Filtering for IPv4 on (IPv6 should be on and set to reject, unless you utilize IPv6 in your network; this is for security reasons), set it to off temporarily, power cycle printer, and attempt registration again.
 
Please be aware, this is not a problem on Google's end and is an issue with the settings on the printer.  If you can't find the setting causing the issue, and/or business support cannot help you narrow down the issue, backup your settings via the Remote UI (both for the printer, as well as information from the Address Book), and reset the printer settings to factory default.  This will solve the issue, albeit you will have to manually figure out afterwards, through trial and error, what setting it was that caused the issue since restoring your printer settings is likely to cause the issue to re-occur until you narrow down the problem setting(s).

alvinbunk
Apprentice

I had this same error and on my MF212w I had to set the Date/Time.

After that I could register my printer on Google Cloud print.


@alvinbunk wrote:

I had this same error and on my MF212w I had to set the Date/Time.

After that I could register my printer on Google Cloud print.


This would normally be pushed to the printer via the router's NTP daemon.

Google Cloud Print suddenly stopped working on my MF733cdw. Here's what fixed it:

 

  • Log in to the web UI as admin
  • Go to Settings/Registration/Preferences/Network Settings/TLS Settings
  • Click "Key and Certificate" under Key and Certificate Settings
  • Click "Register Default Key"

 

I didn't have to re-register Cloud Print or restart the printer.

I have a MF8280Cw and needed to Log into Remote UI (printer)

Register

Network

Cloud Print Settings

Uncheck Verify Server Certificate

 

Don't know how secure this is but I can't log into Remote Ui if I check SSL and when I check SSL certificate nothing is showing. At least I can print. Will think twice about printing anything sensitive.

Howdy y'all. Just won a Google Cloud Print grudge match with my MF8580Cdw. Thought I'd chime in here with some of the things that helped, and some that didn't.

 

My GCP on my 8580 just stopped working one day. No print for you. 😠

 

It seems Google update the CA's on the CloudPrint servers, rendering some printers (mine) unable to login to register their availability to print. The required certificates were not installed. Word on the street is that the manufacturer has to update the firmware & include the newer certificates.

 

However, for me, the solution was to more simply install and register a new CA. I couldn't find a procedure to do exactly what I wanted, so I flailied in the dark until I stumbled upon a solution that worked for me. I hope it works for you too. It's amazing what flailing can do when you're a desperate father trying to get his daughter's Chromebook to print her 5th grade report on the state of Maryland that's due tomorrow.

 

What worked:

- On my Mac OS machine:

     - Go into Keychain Access (Utilities folder), and export all the entries for "GlobalSign" as .cer files.

 

- On the printer's web page:

     - Go to "Settings/Registreation" -> "Security Settings" -> "CA Certificate Settings"

            (Note the absence of GlobalSign in the default certificates)

     - Click the button "Register CA Certificates".

     - Specify one of the .cer files exported above

     - Click Install, then Register

     - Repeat.

           Note: You'll see the previous .cer file again. It's safe to click "Delete" & specify a new file.

           This doesn't delete the registration, just the install file.

     - Go to "Network Settings" -> "CloudPrint Settings" and try to register your printer.

 

Note, no power-cycling of the printer was needed in any of my above procedures.

 

Here were some of the things I tried that didn't work.

- SSL settings enabled/disabled, and all the hoops I jumped thru making my own certificates & keys on the printer, etc. None of that seemed to affect GCP's ability to see my printer.

- Registering the printer with GCP was possible by disabling "Verify Server Certificate", however every print job threw an "error" in the CloudPrint queue.

- A *lot* of restarts

- Initializing all settings (I admit this *may* have contributed to the solution, but even after taking this step, nothing worked until I installed the .cer files above)

 

I hope this helps someone. I'll put this on appropriate GCP discussions that reference the MF8500 series.

I'm assuming you were generating an SSL cert from a self signed CA/ICA?  Whenever a non-commercial CA/ICA is used, the self-signed CA should be concantenated within the SSL cert's file, with the SSL cert listed first in the file, and the CA listed second (if it's a self-signed CA & ICA, certificate would contain the SSL cert, ICA cert, then the CA cert).

  • If the self-signed CA/ICA is not concatenated within the SSL cert, there is no way for Chain of Trust to be verified, hence the reason why you were getting certificate errors

 

All internet ready devices contain a master CA list, either as individual certs or as a master cert will all CA included within, so it's a bit odd that you would have to export a master list of CAs from an Apple product.

I agree. The problem is that Google changed CA's, and Canon has yet to update the firmware with the new GlobalSign CA's registered.

 

The 8500's let you upload cert files & register them. I assume this is mostly for enterprise funcitonality. In my case, I was desperately looking for a certificate file format the 8580 would swallow. So I went looking for sources. Because I'm pretty adept at MacOS, I knew Keychain Access was a possible source. So I went trolling for exports from KA for anything GlobalSign, and I discovered a format the printer would import.

 

I suspect all the Canon was missing was some sort of public key for GlobalSign's CA.

 

I can barely follow all the technicals you mentioned. I'm a total novice at encryption concepts. I just found a procedure that solved the problem I needed solved, and it didn't seem to matter whether or not SSL was enabled in the machine.

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x