cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Brand new Canon Maxify MB2720 not printing with chromebook or iphone

autumnwicka
Apprentice

We bought a new printer for the office, reviewed all the features and decided on the canon Maxify MB2720.

 

It worked the first few days and slowly stopped. First we could print only one copy at a time from chromebooks. Now I cannot print at all from my chromebook - which is supported by this specific printer per the user manual. 

 

I then tried to use airprint from my iphone and it still won't print. It will still print from the office desktop compueters using wifi connection, and will copy. It has never been able to scan to any device either. I have searched many forums to find a solution with no help.

1 REPLY 1

ArthurJ
Product Expert
Product Expert

Hi,

You can try turning off the IPV6 setting to see if the printer can be detected via AirPrint and your Chromebooks. Please use the steps HERE

If the issue persists, I recommend you reach out to Canon support. Our team will be able to assist you in real time with this matter. You will need to register your Canon gear HERE to access additional support options.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Avatar
click here to view the gallery
Announcements