Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎08-08-2017

Canon Pixma 7550 - showing as printer not connected

My canon MG7550 has suddenly stopped printing wirelessly from my Mac and shows as 'Printer not connected' when trying to print.  Having tried to delete and reinstall the printer software, I can't get through the set-up as the printer could not be found.  It looks to be connected to the router ok (it is coming up ok as an AirPrint printer on my iphone, just not from my mac).  I have tried disabling IPv6 and LAN DRX settings as suggested in another post to no avail.  I also helpfully cant find the USB cable as I have only ever printed wirelessly.  

 

Any ideas as its infuriating me! 

Moderator
Posts: 1,674
Registered: ‎07-08-2013

Re: Canon Pixma 7550 - showing as printer not connected

Hi, kadrummo!

Welcome to The Canon Forums, and thanks for posting!

We appreciate your participation, though we need to let you know that your product appears to be a model that is not supported by our team here at Canon USA.  The Canon Community Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please click HERE and select your country to find support in your part of the world.

Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

Thanks for choosing Canon!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement