cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SX280 - battery life shooting video

factoryguy
Apprentice

UPDATED May 5:

 

I apologize to the forum for mixing two different problems.  They are unrelated.

 

Problem #1:  User error.  I thought I was using a class 6 SD card but I was wrong. The yellow "!" indicates a pathologically slow card.  Upgrading to a class 10 resolved this problem.

 

Problem #2: UNRESOLVED.  Red battery indicator comes on prematurely.  On a fresh charge, it'll turn red after recording for a couple of minutes.  On a partially drained battery, it turns red immediately upon entering movie mode or pressing the record button.  Turn the camera off and then right back on in "still" mode and it shows full charge and works fine ... until trying to shoot video.  I have not precisely measured recording times but it'll record for at least 20 (maybe 30?) minutes while flashing red.

 

 

 

1,334 REPLIES 1,334

Not to mention the shutter button problem thread on this site.

Let the buyer beware!

None of them Davy.

@ruko

 

Sure is getting that way, what puts me off is their attitude and the way they treat customers with their 'after sales' service.... it puts me off completely.

 

We can accept a camera giving trouble once in a while but not a whole bunch of them - that stinks!  The very least they could have done with these SX280 owners (and S100's) is to come up with a compromise.

 

If I buy a new camera I don't want to be ending up with a refurbished unit, I want be having a brand new one or my money back!

 

It sticks out like a sore thumb, come out with a camera that uses 'standard'  dry batteries or standard rechargeables *may*  prove to be a winner...... if they had done that with the SX280/700 the reaction may well have been entirely different with fewer complaints.

 

Dave

I have purchased SX280 HS camera from Amazon paying $299. I am not a power photographer and I use my camera 2-3 times a year when I go abroad or on holiday. I might have taken 2-3k pictures until now. I had the same premature battery warning when shooting video and I updated firmware (1.0.2.0). It resolved this issue but it caused other ones! Now neither can I use my flash nor GPS. Flash malfunctions all the time. Anyone experienced the same? Any solutions to this?

 

Thank you.

After contacting Canon CS, this is what I got as a reply:

 

" Thank you for contacting Canon product support.  I understand that your PowerShot SX280 HS camera has malfunctioned.  I know how frustrating this can be.

The age of your camera and/or the cause of the malfunction will determine your service options.  If the camera is more than one year old, or if the camera was damaged by liquid, sand, or applied pressure or force, it is out of warranty.  We have two options available for out of warranty cameras:  you may participate in the Canon Loyalty Program, or you can send the camera in for repair.  If the camera was purchased less than one year ago, and you have a copy of your sales receipt, the unit can be sent to our Factory Service Center for repair. 

One option you have is the Canon Loyalty Program.  This program allows you to replace your current camera with a refurbished Canon Camera for a discounted fee, and have it shipped via Ground delivery.  The refurbished unit offered through this program carries a one year warranty.  The original non-functioning camera would then be returned to Canon USA for recycling using a prepaid shipping label that would be provided.  If you would like to take part in this option, please call our Sales Department at (866) 443-8002 seven days a week, 8am to Midnight.  Let them know you have been working with email technical support and the Canon Loyalty Program was offered.  Be sure to have your serial number for your camera at the time of your call.

If your camera is in warranty, or you prefer to have it repaired, please forward your digital camera to the Factory Service Center shown below.  When shipping your camera, please be sure to remove the memory card and battery.  You are not required to send any accessories or manuals when shipping the camera.  Be sure to include your name, street address (no P.O. boxes, please), telephone number, and a letter describing the issue with the product.

As we do not provide RMA numbers for service, we suggest using a trackable and insurable service (i.e. UPS, Federal Express, Priority Mail) to ship your camera.  Please package the camera very securely to prevent damage during shipment.

Please send your camera to the following address:

Canon Factory Service
12022 Canon Boulevard
Newport News, VA 23606

Upon arrival at the Factory Service Center, your camera will be logged in to our repair database and assigned a repair number.  Next, the camera will be visually inspected and you will be advised of the findings.
 
A written estimate will be sent to you at the address that you have provided.  The repairs to your camera will not begin until you approve this estimate and make payment arrangements.  If, after receiving the estimate, you do not wish to have the camera repaired, please inform the Factory Service Center of your decision as soon as possible.  If you decline the estimate, the camera will be shipped back to you unrepaired.

When the repairs are complete, the camera will be shipped back to you via Federal Express or UPS.  The length of time for the repair will be dependent upon the nature of the repair and availability of parts, if needed.  Usually, repairs are completed within approximately seven to ten business days of payment.

Once you have confirmed with your shipper that the camera has been delivered, you are more than welcome to contact us for repair updates.  Please include your name, address, and telephone number, as well as the serial number of the camera, in all repair status inquiries. 

For non-warranty repairs, the standard labor cost to make the repair is $174.99.  Parts may be an additional cost.  Cameras damaged by liquid, sand, or applied pressure or force may have a considerably higher repair cost, depending on the results of the Factory Service Center's evaluation.

I hope this information is helpful to you. Please let us know if we can be of any further assistance with your PowerShot SX280 HS camera. Thank you for choosing Canon."

 

 

They request minimum $175 for defective product out of the box!! How can this be!? I don't use my camera frequently and I have just discovered its issues. One shouldn't pay for a defective out-of-the-box product and should be compensated either by a refund or a new product! Canon should recall these cameras!

You've discovered what the rest of have been struggling with - a company that has your money and could care less about anything else. This camera was, is, and will always be a lemon. Buyer beware.

It was my first Canon experience and it will be the last.

 

The above post is not very helpful........

 

How long have you owned the camera? (If I look at the U shaped price curve it would seem like you purchased in May 2013)

 

The two issues you mention - flash and GPS - have not been issues experienced by people contributing to this particular message board. The issue here is insufficient battery power to allow multiple operations while using the highest quality video.

 

I have read most of the contributions on this subject and I do not believe that a software update has ever caused flash and GPS malfunctions. I hope if someone has experienced this they will detail what their resolution was.

Actually, I think the post was extremely helpful. The SX280 is an exercise in corporate hubris. Canon made a lackluster camera, and a loyal customer refuses to sink any more money into a company with utter disdain for its customers who dare expect a camera an accurate battery meter. 

@ peterdev

 

I am talking about stand still image capability of this camera, which in fact must be capable of since it is a camera not a video recorder. I am not facing problem with video recording unlike taking pictures. In none of modes flash is working even when the battery is fully charged. Don't you think this is an issue? I also get a strange noise when when I am not playing with the camera (i.e. zooming in/out etc.). I strongly believe that this camera is faulty out-of-the-box. I have just discovered it because I have not been using it frequently though I have owned it more than a year.

Avatar
click here to view the press release
Announcements